summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2016-11-16 21:40:27 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-11-17 23:08:35 +1100
commit3d5c2acaa71b0c1b65738d2ef2d6ede47f2fb76b (patch)
tree619f235fb15ecbd9d37cf0789d152f80246ddb9e /games-emulation
parentdev-util/codeblocks: remove unused patches (diff)
downloadgentoo-3d5c2acaa71b0c1b65738d2ef2d6ede47f2fb76b.tar.gz
gentoo-3d5c2acaa71b0c1b65738d2ef2d6ede47f2fb76b.tar.bz2
gentoo-3d5c2acaa71b0c1b65738d2ef2d6ede47f2fb76b.zip
games-emulation/dolphin: remove unused patches
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/files/dolphin-5.0-dynamic-llvm-detect.patch54
-rw-r--r--games-emulation/dolphin/files/dolphin-5.0-miniupnpc-abi-14.patch137
-rw-r--r--games-emulation/dolphin/files/dolphin-emu-3.5-gcc-4.8.patch211
3 files changed, 0 insertions, 402 deletions
diff --git a/games-emulation/dolphin/files/dolphin-5.0-dynamic-llvm-detect.patch b/games-emulation/dolphin/files/dolphin-5.0-dynamic-llvm-detect.patch
deleted file mode 100644
index 798ec56a4fac..000000000000
--- a/games-emulation/dolphin/files/dolphin-5.0-dynamic-llvm-detect.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 1515497ab88dc2452ed0db20a4610663cd04ff21 Mon Sep 17 00:00:00 2001
-From: comex <comexk@gmail.com>
-Date: Tue, 7 Jul 2015 07:49:46 -0400
-Subject: [PATCH] Make the LLVM detect script verify that the dynamic library actually exists.
-
-For some dumb reason, llvm-config doesn't provide the flags to link
-against the dynamic library copy of LLVM (as opposed to static), so the
-script has to guess the library name. However, in some installations
-(such as mine), there is no dynamic copy, which caused Dolphin to fail
-to link. Change the script to do a link test. If it fails, one option
-would be to fall back on static linking, but I just have it fail to
-detect LLVM, because statically linking Dolphin against LLVM is really
-not a great idea - huge binary, long link time.
----
- CMakeTests/FindLLVM.cmake | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/CMakeTests/FindLLVM.cmake b/CMakeTests/FindLLVM.cmake
-index 7fe664f..cfcfaed 100644
---- a/CMakeTests/FindLLVM.cmake
-+++ b/CMakeTests/FindLLVM.cmake
-@@ -1,6 +1,9 @@
- # This file only exists because LLVM's cmake files are broken.
- # This affects both LLVM 3.4 and 3.5.
- # Hopefully when they fix their cmake system we don't need this garbage.
-+
-+include(CheckLibraryExists)
-+
- list(APPEND LLVM_CONFIG_EXECUTABLES "llvm-config")
- list(APPEND LLVM_CONFIG_EXECUTABLES "llvm-config-3.5")
- list(APPEND LLVM_CONFIG_EXECUTABLES "llvm-config-3.4")
-@@ -11,13 +14,16 @@ foreach(LLVM_CONFIG_NAME ${LLVM_CONFIG_EXECUTABLES})
- execute_process(COMMAND ${LLVM_CONFIG_EXE} --version OUTPUT_VARIABLE LLVM_PACKAGE_VERSION
- OUTPUT_STRIP_TRAILING_WHITESPACE )
- if (${LLVM_PACKAGE_VERSION} VERSION_GREATER "3.3")
-- set(LLVM_FOUND 1)
- execute_process(COMMAND ${LLVM_CONFIG_EXE} --includedir OUTPUT_VARIABLE LLVM_INCLUDE_DIRS
- OUTPUT_STRIP_TRAILING_WHITESPACE )
- execute_process(COMMAND ${LLVM_CONFIG_EXE} --ldflags OUTPUT_VARIABLE LLVM_LDFLAGS
- OUTPUT_STRIP_TRAILING_WHITESPACE )
-- set(LLVM_LIBRARIES "${LLVM_LDFLAGS} -lLLVM-${LLVM_PACKAGE_VERSION}")
-- break()
-+ check_library_exists(LLVM-${LLVM_PACKAGE_VERSION} LLVMVerifyFunction "${LLVM_LDFLAGS}" HAVE_DYNAMIC_LLVM_${LLVM_PACKAGE_VERSION})
-+ if (HAVE_DYNAMIC_LLVM_${LLVM_PACKAGE_VERSION})
-+ set(LLVM_LIBRARIES "${LLVM_LDFLAGS} -lLLVM-${LLVM_PACKAGE_VERSION}")
-+ set(LLVM_FOUND 1)
-+ break()
-+ endif()
- endif()
- endif()
- endforeach()
---
-2.6.2
-
diff --git a/games-emulation/dolphin/files/dolphin-5.0-miniupnpc-abi-14.patch b/games-emulation/dolphin/files/dolphin-5.0-miniupnpc-abi-14.patch
deleted file mode 100644
index ecb6abba8e12..000000000000
--- a/games-emulation/dolphin/files/dolphin-5.0-miniupnpc-abi-14.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-From 8c5744bca705a0895bd51c966a30171ee2bab43a Mon Sep 17 00:00:00 2001
-From: Marisa Kirisame <marisa@sayachan.org>
-Date: Tue, 29 Sep 2015 23:10:31 +0200
-Subject: [PATCH] miniupnpc API version 14 changed the upnpDiscover functions,
- adding an argument for TTL (should default to 2) this enables support for
- that should the build system have that specific version installed, the
- miniupnpc bundled in the project is unchanged
-
----
- CMakeLists.txt | 5 ++++-
- CMakeTests/FindMiniupnpc.cmake | 39 +++++++++++++++++++++++++++++++++-----
- Source/Core/Core/NetPlayServer.cpp | 4 ++++
- 3 files changed, 42 insertions(+), 6 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 291efee..7ac0679 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -690,9 +690,12 @@ if(USE_UPNP)
- if(NOT APPLE AND NOT ANDROID)
- include(FindMiniupnpc)
- endif()
-- if(MINIUPNP_FOUND AND MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+ if(MINIUPNP_FOUND AND (MINIUPNPC_VERSION_1_7_OR_HIGHER OR MINIUPNPC_VERSION_API14_OR_HIGHER))
- message("Using shared miniupnpc")
- include_directories(${MINIUPNP_INCLUDE_DIR})
-+ if (MINIUPNPC_VERSION_API14_OR_HIGHER)
-+ add_definitions(-DUPNPDISCOVER_HAS_TTL)
-+ endif()
- else()
- message("Using static miniupnpc from Externals")
- add_subdirectory(Externals/miniupnpc)
-diff --git a/CMakeTests/FindMiniupnpc.cmake b/CMakeTests/FindMiniupnpc.cmake
-index bb1048c..5301d40 100644
---- a/CMakeTests/FindMiniupnpc.cmake
-+++ b/CMakeTests/FindMiniupnpc.cmake
-@@ -58,6 +58,30 @@ if (MINIUPNP_FOUND)
- #include <stdio.h>
- int main()
- {
-+ struct UPNPDev *devlist = NULL;
-+ int upnp_delay = 5000;
-+ const char *upnp_multicastif = NULL;
-+ const char *upnp_minissdpdsock = NULL;
-+ int upnp_sameport = 0;
-+ int upnp_ipv6 = 0;
-+ unsigned char upnp_ttl = 2;
-+ int upnp_error = 0;
-+ devlist = upnpDiscover(upnp_delay, upnp_multicastif, upnp_minissdpdsock, upnp_sameport, upnp_ipv6, upnp_ttl, &upnp_error);
-+
-+ return 0;
-+ }"
-+ MINIUPNPC_VERSION_API14_OR_HIGHER)
-+
-+IF (NOT MINIUPNPC_VERSION_API14_OR_HIGHER)
-+ set(CMAKE_REQUIRED_INCLUDES ${MINIUPNP_INCLUDE_DIR})
-+ set(CMAKE_REQUIRED_LIBRARIES ${MINIUPNP_LIBRARY})
-+ check_cxx_source_runs("
-+ #include <miniwget.h>
-+ #include <miniupnpc.h>
-+ #include <upnpcommands.h>
-+ #include <stdio.h>
-+ int main()
-+ {
- static struct UPNPUrls urls;
- static struct IGDdatas data;
-
-@@ -66,8 +90,9 @@ if (MINIUPNP_FOUND)
- return 0;
- }"
- MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+ ENDIF()
-
--IF (NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+IF (NOT MINIUPNPC_VERSION_1_7_OR_HIGHER AND NOT MINIUPNPC_VERSION_API14_OR_HIGHER)
- set(CMAKE_REQUIRED_INCLUDES ${MINIUPNP_INCLUDE_DIR})
- set(CMAKE_REQUIRED_LIBRARIES ${MINIUPNP_LIBRARY})
- check_cxx_source_runs("
-@@ -91,7 +116,7 @@ IF (NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
- MINIUPNPC_VERSION_PRE1_7)
- ENDIF()
-
-- IF (NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+ IF (NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER AND NOT MINIUPNPC_VERSION_API14_OR_HIGHER)
- set(CMAKE_REQUIRED_INCLUDES ${MINIUPNP_INCLUDE_DIR})
- set(CMAKE_REQUIRED_LIBRARIES ${MINIUPNP_LIBRARY})
- check_cxx_source_runs("
-@@ -116,7 +141,7 @@ IF (NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
-
- ENDIF()
-
-- IF (NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+ IF (NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER AND NOT MINIUPNPC_VERSION_API14_OR_HIGHER)
- set(CMAKE_REQUIRED_INCLUDES ${MINIUPNP_INCLUDE_DIR})
- set(CMAKE_REQUIRED_LIBRARIES ${MINIUPNP_LIBRARY})
- check_cxx_source_runs("
-@@ -136,7 +161,7 @@ IF (NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
- MINIUPNPC_VERSION_1_5_OR_HIGHER)
- ENDIF()
-
-- IF (NOT MINIUPNPC_VERSION_1_5_OR_HIGHER AND NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+ IF (NOT MINIUPNPC_VERSION_1_5_OR_HIGHER AND NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER AND NOT MINIUPNPC_VERSION_API14_OR_HIGHER)
- set(CMAKE_REQUIRED_INCLUDES ${MINIUPNP_INCLUDE_DIR})
- set(CMAKE_REQUIRED_LIBRARIES ${MINIUPNP_LIBRARY})
- check_cxx_source_runs("
-@@ -167,10 +192,14 @@ IF(MINIUPNPC_VERSION_PRE1_7)
- message(STATUS "Found miniupnpc version is pre v1.7")
- ENDIF()
-
--IF(NOT MINIUPNPC_VERSION_PRE1_5 AND NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7)
-+IF(NOT MINIUPNPC_VERSION_PRE1_5 AND NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_API14_OR_HIGHER)
- message(STATUS "Found miniupnpc version is v1.7 or higher")
- ENDIF()
-
-+IF(NOT MINIUPNPC_VERSION_PRE1_5 AND NOT MINIUPNPC_VERSION_PRE1_6 AND NOT MINIUPNPC_VERSION_PRE1_7 AND NOT MINIUPNPC_VERSION_1_7_OR_HIGHER)
-+ message(STATUS "Found miniupnpc version is v1.9 API version 14 or higher")
-+ENDIF()
-+
- else ()
- message (STATUS "Could not find miniupnp")
- endif ()
-diff --git a/Source/Core/Core/NetPlayServer.cpp b/Source/Core/Core/NetPlayServer.cpp
-index 7ed283a..27b46c9 100644
---- a/Source/Core/Core/NetPlayServer.cpp
-+++ b/Source/Core/Core/NetPlayServer.cpp
-@@ -904,7 +904,11 @@ bool NetPlayServer::initUPnP()
- memset(&m_upnp_data, 0, sizeof(IGDdatas));
-
- // Find all UPnP devices
-+#ifdef UPNPDISCOVER_HAS_TTL
-+ UPNPDev *devlist = upnpDiscover(2000, nullptr, nullptr, 0, 0, 2, &upnperror);
-+#else
- UPNPDev *devlist = upnpDiscover(2000, nullptr, nullptr, 0, 0, &upnperror);
-+#endif
- if (!devlist)
- {
- WARN_LOG(NETPLAY, "An error occured trying to discover UPnP devices.");
diff --git a/games-emulation/dolphin/files/dolphin-emu-3.5-gcc-4.8.patch b/games-emulation/dolphin/files/dolphin-emu-3.5-gcc-4.8.patch
deleted file mode 100644
index 98b128f90542..000000000000
--- a/games-emulation/dolphin/files/dolphin-emu-3.5-gcc-4.8.patch
+++ /dev/null
@@ -1,211 +0,0 @@
---- Externals/Bochs_disasm/PowerPCDisasm.cpp 2013-05-04 10:01:04.218490222 +0200
-+++ Externals/Bochs_disasm/PowerPCDisasm.cpp 2013-05-04 10:01:19.159459773 +0200
-@@ -580,7 +580,7 @@
- if (me < mb)
- mask = ~mask;
- //rotate the mask so it can be applied to source reg
-- return _rotl(mask, 32 - r);
-+ return __rotl(mask, 32 - r);
- }
-
-
---- Source/Core/Common/Src/CommonFuncs.h 2013-05-04 10:01:04.139490384 +0200
-+++ Source/Core/Common/Src/CommonFuncs.h 2013-05-04 10:02:18.181339068 +0200
-@@ -65,7 +65,7 @@
- #endif
- #define ARRAYSIZE(A) (sizeof(A)/sizeof((A)[0]))
-
--inline u32 _rotl(u32 x, int shift) {
-+inline u32 __rotl(u32 x, int shift) {
- shift &= 31;
- if (!shift) return x;
- return (x << shift) | (x >> (32 - shift));
-@@ -76,7 +76,7 @@
- return (x << n) | (x >> (64 - n));
- }
-
--inline u32 _rotr(u32 x, int shift) {
-+inline u32 __rotr(u32 x, int shift) {
- shift &= 31;
- if (!shift) return x;
- return (x >> shift) | (x << (32 - shift));
---- Source/Core/Common/Src/Hash.cpp 2013-05-04 10:01:04.140490382 +0200
-+++ Source/Core/Common/Src/Hash.cpp 2013-05-04 10:01:19.161459756 +0200
-@@ -362,15 +362,15 @@
- inline void bmix32(u32 & h1, u32 & h2, u32 & k1, u32 & k2, u32 & c1, u32 & c2)
- {
- k1 *= c1;
-- k1 = _rotl(k1,11);
-+ k1 = __rotl(k1,11);
- k1 *= c2;
- h1 ^= k1;
- h1 += h2;
-
-- h2 = _rotl(h2,17);
-+ h2 = __rotl(h2,17);
-
- k2 *= c2;
-- k2 = _rotl(k2,11);
-+ k2 = __rotl(k2,11);
- k2 *= c1;
- h2 ^= k2;
- h2 += h1;
---- Source/Core/Core/Src/ARDecrypt.cpp 2013-05-04 10:01:04.193490273 +0200
-+++ Source/Core/Core/Src/ARDecrypt.cpp 2013-05-04 10:01:19.161459756 +0200
-@@ -270,26 +270,26 @@
- {
- u32 tmp;
-
-- *val = _rotl(*val,4);
-+ *val = __rotl(*val,4);
-
- tmp = ((*addr^*val)&0xF0F0F0F0);
- *addr ^= tmp;
-- *val = _rotr((*val^tmp),0x14);
-+ *val = __rotr((*val^tmp),0x14);
-
- tmp = ((*addr^*val)&0xFFFF0000);
- *addr ^= tmp;
-- *val = _rotr((*val^tmp),0x12);
-+ *val = __rotr((*val^tmp),0x12);
-
- tmp = ((*addr^*val)&0x33333333);
- *addr ^= tmp;
-- *val = _rotr((*val^tmp),6);
-+ *val = __rotr((*val^tmp),6);
-
- tmp = ((*addr^*val)&0x00FF00FF);
- *addr ^= tmp;
-- *val = _rotl((*val^tmp),9);
-+ *val = __rotl((*val^tmp),9);
-
- tmp = ((*addr^*val)&0xAAAAAAAA);
-- *addr = _rotl((*addr^tmp),1);
-+ *addr = __rotl((*addr^tmp),1);
- *val ^= tmp;
- }
-
-@@ -297,27 +297,27 @@
- {
- u32 tmp;
-
-- *val = _rotr(*val,1);
-+ *val = __rotr(*val,1);
-
- tmp = ((*addr^*val)&0xAAAAAAAA);
- *val ^= tmp;
-- *addr = _rotr((*addr^tmp),9);
-+ *addr = __rotr((*addr^tmp),9);
-
- tmp = ((*addr^*val)&0x00FF00FF);
- *val ^= tmp;
-- *addr = _rotl((*addr^tmp),6);
-+ *addr = __rotl((*addr^tmp),6);
-
- tmp = ((*addr^*val)&0x33333333);
- *val ^= tmp;
-- *addr = _rotl((*addr^tmp),0x12);
-+ *addr = __rotl((*addr^tmp),0x12);
-
- tmp = ((*addr^*val)&0xFFFF0000);
- *val ^= tmp;
-- *addr = _rotl((*addr^tmp),0x14);
-+ *addr = __rotl((*addr^tmp),0x14);
-
- tmp = ((*addr^*val)&0xF0F0F0F0);
- *val ^= tmp;
-- *addr = _rotr((*addr^tmp),4);
-+ *addr = __rotr((*addr^tmp),4);
- }
-
- void decryptcode(u32 *seeds, u32 *code)
-@@ -330,11 +330,11 @@
- unscramble1(&addr,&val);
- while (i < 32)
- {
-- tmp = (_rotr(val,4)^seeds[i++]);
-+ tmp = (__rotr(val,4)^seeds[i++]);
- tmp2 = (val^seeds[i++]);
- addr ^= (table6[tmp&0x3F]^table4[(tmp>>8)&0x3F]^table2[(tmp>>16)&0x3F]^table0[(tmp>>24)&0x3F]^table7[tmp2&0x3F]^table5[(tmp2>>8)&0x3F]^table3[(tmp2>>16)&0x3F]^table1[(tmp2>>24)&0x3F]);
-
-- tmp = (_rotr(addr,4)^seeds[i++]);
-+ tmp = (__rotr(addr,4)^seeds[i++]);
- tmp2 = (addr^seeds[i++]);
- val ^= (table6[tmp&0x3F]^table4[(tmp>>8)&0x3F]^table2[(tmp>>16)&0x3F]^table0[(tmp>>24)&0x3F]^table7[tmp2&0x3F]^table5[(tmp2>>8)&0x3F]^table3[(tmp2>>16)&0x3F]^table1[(tmp2>>24)&0x3F]);
- }
---- Source/Core/Core/Src/PowerPC/Interpreter/Interpreter_Integer.cpp 2013-05-04 10:01:04.187490286 +0200
-+++ Source/Core/Core/Src/PowerPC/Interpreter/Interpreter_Integer.cpp 2013-05-04 10:01:19.162459748 +0200
-@@ -194,21 +194,21 @@
- void Interpreter::rlwimix(UGeckoInstruction _inst)
- {
- u32 mask = Helper_Mask(_inst.MB,_inst.ME);
-- m_GPR[_inst.RA] = (m_GPR[_inst.RA] & ~mask) | (_rotl(m_GPR[_inst.RS],_inst.SH) & mask);
-+ m_GPR[_inst.RA] = (m_GPR[_inst.RA] & ~mask) | (__rotl(m_GPR[_inst.RS],_inst.SH) & mask);
- if (_inst.Rc) Helper_UpdateCR0(m_GPR[_inst.RA]);
- }
-
- void Interpreter::rlwinmx(UGeckoInstruction _inst)
- {
- u32 mask = Helper_Mask(_inst.MB,_inst.ME);
-- m_GPR[_inst.RA] = _rotl(m_GPR[_inst.RS],_inst.SH) & mask;
-+ m_GPR[_inst.RA] = __rotl(m_GPR[_inst.RS],_inst.SH) & mask;
- if (_inst.Rc) Helper_UpdateCR0(m_GPR[_inst.RA]);
- }
-
- void Interpreter::rlwnmx(UGeckoInstruction _inst)
- {
- u32 mask = Helper_Mask(_inst.MB,_inst.ME);
-- m_GPR[_inst.RA] = _rotl(m_GPR[_inst.RS], m_GPR[_inst.RB] & 0x1F) & mask;
-+ m_GPR[_inst.RA] = __rotl(m_GPR[_inst.RS], m_GPR[_inst.RB] & 0x1F) & mask;
-
- if (_inst.Rc) Helper_UpdateCR0(m_GPR[_inst.RA]);
- }
---- Source/Core/Core/Src/PowerPC/Jit64/Jit_Integer.cpp 2013-05-04 10:01:04.185490290 +0200
-+++ Source/Core/Core/Src/PowerPC/Jit64/Jit_Integer.cpp 2013-05-04 10:01:19.190459657 +0200
-@@ -1672,7 +1672,7 @@
- {
- unsigned result = (int)gpr.R(s).offset;
- if (inst.SH != 0)
-- result = _rotl(result, inst.SH);
-+ result = __rotl(result, inst.SH);
- result &= Helper_Mask(inst.MB, inst.ME);
- gpr.SetImmediate32(a, result);
- if (inst.Rc)
-@@ -1739,7 +1739,7 @@
- if (gpr.R(a).IsImm() && gpr.R(s).IsImm())
- {
- u32 mask = Helper_Mask(inst.MB,inst.ME);
-- gpr.SetImmediate32(a, ((u32)gpr.R(a).offset & ~mask) | (_rotl((u32)gpr.R(s).offset,inst.SH) & mask));
-+ gpr.SetImmediate32(a, ((u32)gpr.R(a).offset & ~mask) | (__rotl((u32)gpr.R(s).offset,inst.SH) & mask));
- if (inst.Rc)
- {
- ComputeRC(gpr.R(a));
-@@ -1824,7 +1824,7 @@
- u32 mask = Helper_Mask(inst.MB, inst.ME);
- if (gpr.R(b).IsImm() && gpr.R(s).IsImm())
- {
-- gpr.SetImmediate32(a, _rotl((u32)gpr.R(s).offset, (u32)gpr.R(b).offset & 0x1F) & mask);
-+ gpr.SetImmediate32(a, __rotl((u32)gpr.R(s).offset, (u32)gpr.R(b).offset & 0x1F) & mask);
- if (inst.Rc)
- {
- ComputeRC(gpr.R(a));
---- Source/Core/Core/Src/PowerPC/Jit64IL/IR.cpp 2013-05-04 10:01:04.188490284 +0200
-+++ Source/Core/Core/Src/PowerPC/Jit64IL/IR.cpp 2013-05-04 10:01:19.191459655 +0200
-@@ -248,7 +248,7 @@
- return 0;
- case Rol:
- if (isImm(*getOp2(I))) {
-- return _rotl(ComputeKnownZeroBits(getOp1(I)),
-+ return __rotl(ComputeKnownZeroBits(getOp1(I)),
- GetImmValue(getOp2(I)));
- }
- default:
-@@ -844,7 +844,7 @@
- InstLoc IRBuilder::FoldRol(InstLoc Op1, InstLoc Op2) {
- if (isImm(*Op2)) {
- if (isImm(*Op1))
-- return EmitIntConst(_rotl(GetImmValue(Op1),
-+ return EmitIntConst(__rotl(GetImmValue(Op1),
- GetImmValue(Op2)));
- if (!(GetImmValue(Op2) & 31)) return Op1;
- }