summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-04 15:29:49 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-04 15:30:06 +0100
commit55f43470369cb639b280de81d56b9e4b00d3bd0a (patch)
treeef86f7403031e6b438b720aebe7a1164ae11593d /games-emulation
parentgnome-base/dconf: Add ~riscv keyword (diff)
downloadgentoo-55f43470369cb639b280de81d56b9e4b00d3bd0a.tar.gz
gentoo-55f43470369cb639b280de81d56b9e4b00d3bd0a.tar.bz2
gentoo-55f43470369cb639b280de81d56b9e4b00d3bd0a.zip
games-emulation/dosbox-staging: 0.76.0 bump
Add support for fluidsynth MIDI with USE flag Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox-staging/Manifest1
-rw-r--r--games-emulation/dosbox-staging/dosbox-staging-0.76.0.ebuild59
-rw-r--r--games-emulation/dosbox-staging/metadata.xml1
3 files changed, 61 insertions, 0 deletions
diff --git a/games-emulation/dosbox-staging/Manifest b/games-emulation/dosbox-staging/Manifest
index b6c0a4be8d99..ddd2c12b6a49 100644
--- a/games-emulation/dosbox-staging/Manifest
+++ b/games-emulation/dosbox-staging/Manifest
@@ -1,2 +1,3 @@
DIST dosbox-staging-0.75.1.tar.gz 1806471 BLAKE2B 5f9f8038327eb46c2c2b5035ca8e2cc93660bb6ce1dfa9572bf67278f14455db723104c0ab4e90b805cc7dbf253f61528ad6a31edb574af57e106f613958aede SHA512 3e14354e4eb697514c4348af2e73e9f2fb84cc3796b5cfea37faac355bd93a54b0f9c717bf0ab75d824cf34e3ee0d40546e2bbf80bc924a37bd8f981f054e4e9
DIST dosbox-staging-0.75.2.tar.gz 1816233 BLAKE2B 0cb3224a1fe0e01e5069b78c91191f33b6d84dfb21b00ed8cd832225e68e5f66e841506bc7c887da462727b931a6c72b84dbf5e48e4dde21dbf62ffa3da4edc6 SHA512 2988b2cc44d041193d900efc4c6fa516aca6246e51c1dece9b207bd3549a8c76c5bcb2f3f5a90da6bb2b573663bddd0020274f17130548aef9cef1f4adf79220
+DIST dosbox-staging-0.76.0.tar.gz 1908605 BLAKE2B 71b3c3d6a6444e2442d54b1db365ea66c9ee3db703be876facb8425355d82d817c080e005cefd103714e15fc7d1c17d6329c28d67bf74c143d0428e4f58e5142 SHA512 8c0357bcec08cac2cd2b306edd8b51ad05e16a3c3efb1f4c77e1d942f285493cae8aab45f1633e9c168c0b4b45aa289cf3ffc72685dc004d83127cdb6c76ae9d
diff --git a/games-emulation/dosbox-staging/dosbox-staging-0.76.0.ebuild b/games-emulation/dosbox-staging/dosbox-staging-0.76.0.ebuild
new file mode 100644
index 000000000000..7e127ad865ea
--- /dev/null
+++ b/games-emulation/dosbox-staging/dosbox-staging-0.76.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop flag-o-matic xdg
+
+DESCRIPTION="Modernized DOSBox soft-fork"
+HOMEPAGE="https://dosbox-staging.github.io/"
+SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa debug dynrec +fluidsynth network opengl opus"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ debug? ( sys-libs/ncurses:0= )
+ fluidsynth? (
+ media-sound/fluid-soundfont
+ media-sound/fluidsynth
+ )
+ network? ( media-libs/sdl2-net )
+ opengl? ( virtual/opengl )
+ opus? ( media-libs/opusfile )
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,opengl?,video,X]
+ sys-libs/zlib
+ !games-emulation/dosbox"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+
+ # We do not have default.sf2, use actual name from fluid-soundfont
+ sed -e "s/default.sf2/FluidR3_GM.sf2/" \
+ -i src/midi/midi_fluidsynth.cpp || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-cppflags -DNDEBUG
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable debug) \
+ $(use_enable !dynrec dynamic-x86) \
+ $(use_enable dynrec) \
+ $(use_enable fluidsynth) \
+ $(use_enable network) \
+ $(use_enable opengl) \
+ $(use_enable opus opus-cdda)
+}
+
+src_install() {
+ default
+ doicon -s scalable contrib/icons/${PN}.svg
+ domenu contrib/linux/dosbox-staging.desktop
+}
diff --git a/games-emulation/dosbox-staging/metadata.xml b/games-emulation/dosbox-staging/metadata.xml
index 91406d636bc1..f9ff028304d3 100644
--- a/games-emulation/dosbox-staging/metadata.xml
+++ b/games-emulation/dosbox-staging/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="dynrec">Use recompiling cpu core instead of dynamic x86/x64 specific cpu core</flag>
+ <flag name="fluidsynth">use <pkg>media-sound/fluidsynth</pkg> for MIDI emulation</flag>
<flag name="network">Enable networking features (modem, ipx)</flag>
<flag name="opus">Support compressed audio tracks (.opus) used with CDROM images</flag>
</use>