summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-11 18:30:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-11 18:30:50 +0100
commit659e8ab798786fb847981e3d6bfb241d8fea6921 (patch)
tree87a6ebaf328a7b2c1f355035a44f55e15b184f1e /games-emulation
parentgames-emulation/snes9x: Bump to version 1.54.1 (diff)
downloadgentoo-659e8ab798786fb847981e3d6bfb241d8fea6921.tar.gz
gentoo-659e8ab798786fb847981e3d6bfb241d8fea6921.tar.bz2
gentoo-659e8ab798786fb847981e3d6bfb241d8fea6921.zip
games-emulation/snes9x: Minor fixes in the system-zlib patch.
Package-Manager: portage-2.3.2
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.54.1-system-zlib.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.54.1-system-zlib.patch b/games-emulation/snes9x/files/snes9x-1.54.1-system-zlib.patch
index e5d3c792871c..26025829442c 100644
--- a/games-emulation/snes9x/files/snes9x-1.54.1-system-zlib.patch
+++ b/games-emulation/snes9x/files/snes9x-1.54.1-system-zlib.patch
@@ -1,4 +1,4 @@
-From 22efabdfc5e3578276943a36ef351bf22a7bd061 Mon Sep 17 00:00:00 2001
+From def3936a5353924fb7b9ffa30b8c1c96c9175ca7 Mon Sep 17 00:00:00 2001
From: Lars Wendler <polynomial-c@gentoo.org>
Date: Fri, 11 Nov 2016 17:52:07 +0100
Subject: [PATCH] Introduce --with-system-zip configure flag to use system zip
@@ -57,7 +57,7 @@ index fad1cf2..57f00fb 100644
if JMA
diff --git a/gtk/configure.ac b/gtk/configure.ac
-index 4d21792..e64fac2 100644
+index 4d21792..e3bab4e 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -138,6 +138,12 @@ AC_ARG_WITH(zlib,
@@ -91,7 +91,7 @@ index 4d21792..e64fac2 100644
+ if test check = "$with_system_zip"; then
+ AC_MSG_WARN(Cannot find SYSTEM_ZIP)
+ else
-+ AC_MSG_ERROR(--with-system-zip given but cannot find proper zip)
++ AC_MSG_ERROR(--with-system-zip given but cannot find proper zlib)
+ fi
+ ])
+fi
@@ -219,7 +219,7 @@ index 5849568..aecad31 100644
CCFLAGS = @S9XFLGS@ @S9XDEFS@ $(DEFS)
CFLAGS = $(CCFLAGS)
diff --git a/unix/configure.ac b/unix/configure.ac
-index 3c851dc..dc0e7ba 100644
+index 3c851dc..47f3780 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -201,16 +201,43 @@ AC_ARG_ENABLE([zip],
@@ -253,7 +253,7 @@ index 3c851dc..dc0e7ba 100644
+ fi
+ S9XDEFS="$S9XDEFS -DSYSTEM_ZIP",
+ if test "x${with_system_zip}" != "xcheck"; then
-+ AC_MSG_ERROR([--with-system-zlib requested but no proper zlib found.])
++ AC_MSG_ERROR([--with-system-zip requested but no proper zlib found.])
+ else
+ AC_MSG_WARN([zlib not found. Build without SYSTEM_ZIP support.])
+ fi