summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-22 19:17:07 +0000
committerSam James <sam@gentoo.org>2021-03-22 19:20:47 +0000
commit6ae030c230c3b8039f80e9ccbf4439846cb8fc5e (patch)
tree6e80015037c9587098069a11df2ef0c1e08a333c /games-emulation
parentsys-libs/timezone-data: adjust /etc/localtime logic (diff)
downloadgentoo-6ae030c230c3b8039f80e9ccbf4439846cb8fc5e.tar.gz
gentoo-6ae030c230c3b8039f80e9ccbf4439846cb8fc5e.tar.bz2
gentoo-6ae030c230c3b8039f80e9ccbf4439846cb8fc5e.zip
games-emulation/stella: add 6.5.2
Closes: https://bugs.gentoo.org/680776 Closes: https://bugs.gentoo.org/765820 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/Manifest1
-rw-r--r--games-emulation/stella/stella-6.5.2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index f5dbcd55867b..7fc59ace4a22 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1 +1,2 @@
DIST stella-5.1.3-src.tar.xz 1828448 BLAKE2B 1588e4da3c21ab51d967aa3fae49b14ef5f3121e3907aa83629dbabeab5c190660ad5a53319429f721cc93560c212f530a58675b7c543c9a3fed3e395669c145 SHA512 9aaf6118c999e90e4947e490f61ccebb82ba1ebeccb29b2e4ec1226bdeef83bb36d944791d6f915522c5c6fec74a0bd17ac5ce8fcc5f369281f9cedf06a380a5
+DIST stella-6.5.2-src.tar.xz 6220652 BLAKE2B 8bb51ff15b28436eb83b918ca6123956482e4342c4f9560dcea608a856899a65176c9012146d1a2affe22ee0a589e945424e897853890e23ff503d97b893e32f SHA512 dc7685fd166fad578bce62c961419755db7c4b8ac6e6e2e10f0edfa3b0f63bf43d64119483cc47fc86dfe95e09bc800c27392239aeb68a2ccf37d0f224d6493c
diff --git a/games-emulation/stella/stella-6.5.2.ebuild b/games-emulation/stella/stella-6.5.2.ebuild
new file mode 100644
index 000000000000..c27cb7cd25bf
--- /dev/null
+++ b/games-emulation/stella/stella-6.5.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic gnome2-utils toolchain-funcs
+
+DESCRIPTION="Multi-platform Atari 2600 VCS Emulator"
+HOMEPAGE="https://stella-emu.github.io"
+SRC_URI="https://github.com/stella-emu/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick"
+
+RDEPEND="
+ media-libs/libsdl2[joystick?,opengl,video]
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt )
+HTML_DOCS=( docs/. )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ CXX="$(tc-getCXX)" ./configure \
+ --prefix="/usr" \
+ --bindir="/usr/bin" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="/usr/share" \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ default
+
+ local i
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+
+ domenu src/unix/stella.desktop
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}