summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-05-15 00:26:13 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-05-15 00:26:49 -0400
commit93efc502fb1a3f0db53a9464135bde247225f48d (patch)
treeff3045b9329d4c3c446d4ea24752eb9e8d271452 /games-emulation
parentnet-wireless/chirp: bump (diff)
downloadgentoo-93efc502fb1a3f0db53a9464135bde247225f48d.tar.gz
gentoo-93efc502fb1a3f0db53a9464135bde247225f48d.tar.bz2
gentoo-93efc502fb1a3f0db53a9464135bde247225f48d.zip
games-emulation/sdlmame: improve makefile munging (bug #583044)
Package-Manager: portage-2.2.28
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sdlmame/sdlmame-0.173.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-emulation/sdlmame/sdlmame-0.173.ebuild b/games-emulation/sdlmame/sdlmame-0.173.ebuild
index edac5fe3c2a3..0c3368e48a19 100644
--- a/games-emulation/sdlmame/sdlmame-0.173.ebuild
+++ b/games-emulation/sdlmame/sdlmame-0.173.ebuild
@@ -53,12 +53,12 @@ S=${WORKDIR}
# Function to disable a makefile option
disable_feature() {
- sed -i -e "/$1.*=/s:^:# :" makefile || die
+ sed -i -e "/^[ ]*$1.*=/s:^:# :" makefile || die
}
# Function to enable a makefile option
enable_feature() {
- sed -i -e "/^#.*$1.*=/s:^#::" makefile || die
+ sed -i -e "/^#.*$1.*=/s:^#[ ]*::" makefile || die
}
pkg_setup() {