summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoroptyfr <opty@hotmail.fr>2018-08-09 21:54:13 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-15 22:22:24 +0200
commita0427a72993b9f2dcb084378faef6290895ca334 (patch)
tree42c21a39e3b12d9c5e9be23ef117efad718056f6 /games-emulation
parentdev-tex/biber: add patch to fix perl-5.26 warnings (diff)
downloadgentoo-a0427a72993b9f2dcb084378faef6290895ca334.tar.gz
gentoo-a0427a72993b9f2dcb084378faef6290895ca334.tar.bz2
gentoo-a0427a72993b9f2dcb084378faef6290895ca334.zip
games-emulation/jrommanager: version bump to 1.7_p24-r1
Closes: https://bugs.gentoo.org/663254 Closes: https://github.com/gentoo/gentoo/pull/9522 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/jrommanager/Manifest1
-rw-r--r--games-emulation/jrommanager/jrommanager-1.7_p24-r1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/games-emulation/jrommanager/Manifest b/games-emulation/jrommanager/Manifest
index ab279a242e65..158fd6ea7e8b 100644
--- a/games-emulation/jrommanager/Manifest
+++ b/games-emulation/jrommanager/Manifest
@@ -1 +1,2 @@
DIST JRomManager-1.6b20.zip 9284236 BLAKE2B a874837e90bdd8ec6c55850fd0e61cabeb767f4b4eba6517a11f3de036a6fd95f7507593da7b5247824c38077b12ac52c490f5ec0e72077bd972c78810c58ebd SHA512 5d4a98989bd9eb2ba94dd50fe451308d9a628414e33cdc84814c55bf9679c3779253a8fab895e2f7922e3b837949e8065f2799707aeaab94d79a12ba73d83638
+DIST JRomManager-1.7b24.zip 9293410 BLAKE2B e73456273e6b2ef960bf94f9c0b4f241829474187fbe7205f98f1bf03abfc3e5eeed4803303ede6e937168daf9eed0ea47499addc00eb153269e9228f4bded61 SHA512 e10ad63348d9eba20175b5d620b32876730900abbe2d8bf9add1ba58f2b7f1d54fbd5a94ec937ab8b94f69c29979302630f2e81cba8d10176b83ec65ba55333f
diff --git a/games-emulation/jrommanager/jrommanager-1.7_p24-r1.ebuild b/games-emulation/jrommanager/jrommanager-1.7_p24-r1.ebuild
new file mode 100644
index 000000000000..20874980f9b2
--- /dev/null
+++ b/games-emulation/jrommanager/jrommanager-1.7_p24-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=JRomManager
+MY_PV=${PV/_p/b}
+MY_P="${MY_PN}-${MY_PV}"
+
+inherit desktop
+
+DESCRIPTION="A Mame and Retrogaming Rom Manager, Java alternative to ClrMamePro"
+HOMEPAGE="https://github.com/optyfr/JRomManager"
+SRC_URI="https://github.com/optyfr/${MY_PN}/releases/download/${MY_PV}/${MY_P}.zip"
+QA_PREBUILT="*"
+
+S="${WORKDIR}"
+
+LICENSE="GPL-2 GPL-2-with-classpath-exception BSD-2 MIT Apache-2.0 LGPL-2.1 unRAR"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ default
+
+ sed -e "/dir=.*/s:.*:cd \"${EROOT}/usr/share/${PN}\" || exit:" -i *.sh || die "sed failed!"
+ unzip -j ${MY_PN}.jar "jrm/resources/rom.png" || die
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins *.jar
+ doins -r lib
+ newbin "${MY_PN}-multi.sh" "${PN}"
+ newicon "rom.png" "${PN}.png"
+ make_desktop_entry "${PN}" '' '' 'Utility'
+}