summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:07:03 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:11 +0000
commita5e4f2b243dbaaceed4580d41ec2ff828a104ab6 (patch)
tree53af3a313fb391ca4d37be524fad2acfed7b42a0 /games-emulation
parentmedia-libs/jg: New package, v1.0.0 (diff)
downloadgentoo-a5e4f2b243dbaaceed4580d41ec2ff828a104ab6.tar.gz
gentoo-a5e4f2b243dbaaceed4580d41ec2ff828a104ab6.tar.bz2
gentoo-a5e4f2b243dbaaceed4580d41ec2ff828a104ab6.zip
games-emulation/jgrf: New package, v1.0.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/jgrf/Manifest1
-rw-r--r--games-emulation/jgrf/jgrf-1.0.0.ebuild51
-rw-r--r--games-emulation/jgrf/jgrf-9999.ebuild51
-rw-r--r--games-emulation/jgrf/metadata.xml25
4 files changed, 128 insertions, 0 deletions
diff --git a/games-emulation/jgrf/Manifest b/games-emulation/jgrf/Manifest
new file mode 100644
index 000000000000..32df49564d4a
--- /dev/null
+++ b/games-emulation/jgrf/Manifest
@@ -0,0 +1 @@
+DIST jgrf-1.0.0.tar.bz2 297212 BLAKE2B 4e7056f2638fabd8aed7df29edb630e74258600a15cc3de8c120feea8c935036ac051afb56d83b243fa89a7ecddb16297dea3cd1f5c7a6e71589e6f9abb4ca7a SHA512 33103acc6caac40ff23a0977d031b310c11e4390d6cdbb9bdf4f3d67c1702e2d8b86e801cf762ba8ab3779a7388309667d86d3f574fa387a7bdce9525276fa25
diff --git a/games-emulation/jgrf/jgrf-1.0.0.ebuild b/games-emulation/jgrf/jgrf-1.0.0.ebuild
new file mode 100644
index 000000000000..4c7c4f9abb39
--- /dev/null
+++ b/games-emulation/jgrf/jgrf-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg
+
+DESCRIPTION="The Jolly Good Reference Frontend"
+HOMEPAGE="https://jgemu.gitlab.io/jgrf.html"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD CC0-1.0 MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ dev-libs/miniz
+ dev-libs/openssl:0=[-bindist(-)]
+ media-libs/jg:1=
+ media-libs/libepoxy[egl]
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/speexdsp
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_MD5=1 \
+ USE_EXTERNAL_MINIZ=1
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ USE_EXTERNAL_MD5=1 \
+ USE_EXTERNAL_MINIZ=1
+}
diff --git a/games-emulation/jgrf/jgrf-9999.ebuild b/games-emulation/jgrf/jgrf-9999.ebuild
new file mode 100644
index 000000000000..4c7c4f9abb39
--- /dev/null
+++ b/games-emulation/jgrf/jgrf-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg
+
+DESCRIPTION="The Jolly Good Reference Frontend"
+HOMEPAGE="https://jgemu.gitlab.io/jgrf.html"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD CC0-1.0 MIT ZLIB"
+SLOT="1"
+
+DEPEND="
+ dev-libs/miniz
+ dev-libs/openssl:0=[-bindist(-)]
+ media-libs/jg:1=
+ media-libs/libepoxy[egl]
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/speexdsp
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_MD5=1 \
+ USE_EXTERNAL_MINIZ=1
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ USE_EXTERNAL_MD5=1 \
+ USE_EXTERNAL_MINIZ=1
+}
diff --git a/games-emulation/jgrf/metadata.xml b/games-emulation/jgrf/metadata.xml
new file mode 100644
index 000000000000..936897ef6ed7
--- /dev/null
+++ b/games-emulation/jgrf/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Jolly Good Reference Frontend is the simplest possible
+ frontend for The Jolly Good API. It is intended to remain this
+ way, and to avoid unnecessary feature creep, ensuring that it is
+ easy to learn from. In order to deliver a smooth and enjoyable
+ experience, a few slightly more advanced features are required. In
+ these instances, effort has been taken to ensure readability
+ and understandability of the code that implements these concepts.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/jgrf/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/jgrf</remote-id>
+ </upstream>
+</pkgmetadata>