summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-02 05:25:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-02 06:53:46 -0400
commita9ecc542726215f484d1ae7b6a668041744223e5 (patch)
tree9fd26060d37dd44103718881fbda60e2738a5131 /games-emulation
parentnet-misc/wget: Stabilize 1.21.1 ppc64, #793356 (diff)
downloadgentoo-a9ecc542726215f484d1ae7b6a668041744223e5.tar.gz
gentoo-a9ecc542726215f484d1ae7b6a668041744223e5.tar.bz2
gentoo-a9ecc542726215f484d1ae7b6a668041744223e5.zip
games-emulation/fceux: drop 2.2.3-r100
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/Manifest1
-rw-r--r--games-emulation/fceux/fceux-2.2.3-r100.ebuild69
-rw-r--r--games-emulation/fceux/files/fceux-2.2.3-python3.patch115
-rw-r--r--games-emulation/fceux/metadata.xml3
4 files changed, 0 insertions, 188 deletions
diff --git a/games-emulation/fceux/Manifest b/games-emulation/fceux/Manifest
index f816c7e3e354..61c17d5f22cd 100644
--- a/games-emulation/fceux/Manifest
+++ b/games-emulation/fceux/Manifest
@@ -1,2 +1 @@
-DIST fceux-2.2.3.src.tar.gz 9292792 BLAKE2B 44412934a50f2cab581cb194932a079071e8c7c1cb4cb4d173e9d7cf4898806fe1b0948d6e86fd70d1265eb596c47f77f751e3a113f03aba9b95e1f5def9c2a8 SHA512 6deb83e9e773694f4040f5f325b0b5b4f45d58bb3481db67b4659c940d90c4c87e3ffeac712b72ddb3f5d089cd9fc7b55b497db61f708c23a7c43c17eda55c7b
DIST fceux-2.3.0.src.tar.gz 20779030 BLAKE2B 0d9a0e1f326bdcde4e360a03755c9d807a59e3f3826017e2923527f3ec214bec4c9737f98a8abc4e4971098d127ce8e95eb4142fa8d0bd71109190e6d2c93861 SHA512 46b53f0c4c790ae4f7d5e800adf81cce3c7ccf4b06f972d46e29c0170485e291516709a8c28b26c762d535453e280a6c6de935869c7674bb135c3dca2e266407
diff --git a/games-emulation/fceux/fceux-2.2.3-r100.ebuild b/games-emulation/fceux/fceux-2.2.3-r100.ebuild
deleted file mode 100644
index 710e02367ead..000000000000
--- a/games-emulation/fceux/fceux-2.2.3-r100.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-1 )
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit python-any-r1 desktop lua-single scons-utils toolchain-funcs
-
-DESCRIPTION="A portable Famicom/NES emulator, an evolution of the original FCE Ultra"
-HOMEPAGE="https://fceux.com/"
-SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk logo +lua +opengl"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- lua? ( ${LUA_DEPS} )
- media-libs/libsdl[opengl?,video]
- logo? ( media-libs/gd[png] )
- opengl? ( virtual/opengl )
- gtk? ( x11-libs/gtk+:3 )
- sys-libs/zlib[minizip]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2.2-warnings.patch
- "${FILESDIR}/${P}-python3.patch"
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- default
-
- tc-export CC CXX
-}
-
-src_compile() {
- escons \
- GTK=0 \
- CREATE_AVI=1 \
- SYSTEM_LUA=1 \
- SYSTEM_MINIZIP=1 \
- GTK3=$(usex gtk 1 0) \
- LOGO=$(usex logo 1 0) \
- OPENGL=$(usex opengl 1 0) \
- LUA=$(usex lua 1 0)
-}
-
-src_install() {
- dobin bin/fceux
-
- doman documentation/fceux.6
- docompress -x /usr/share/doc/${PF}/documentation /usr/share/doc/${PF}/fceux.chm
- dodoc -r Authors changelog.txt TODO-SDL bin/fceux.chm documentation
- rm -f "${D}/usr/share/doc/${PF}/documentation/fceux.6"
- make_desktop_entry fceux FCEUX
- doicon fceux.png
-}
diff --git a/games-emulation/fceux/files/fceux-2.2.3-python3.patch b/games-emulation/fceux/files/fceux-2.2.3-python3.patch
deleted file mode 100644
index c08c67058d22..000000000000
--- a/games-emulation/fceux/files/fceux-2.2.3-python3.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-This is upstream's patch to fix Python 3 building, modified to apply against 2.2.3.
-
-https://github.com/TASVideos/fceux/commit/878245fedf028f8c9373be128dbea01f65d4a8b7
-
-diff --git a/SConstruct b/SConstruct
-index be84421..4b60484 100644
---- a/SConstruct
-+++ b/SConstruct
-@@ -46,30 +46,30 @@ if platform.system == "ppc":
- # Default compiler flags:
- env.Append(CCFLAGS = ['-Wall', '-Wno-write-strings', '-Wno-sign-compare'])
-
--if os.environ.has_key('PLATFORM'):
-+if 'PLATFORM' in os.environ:
- env.Replace(PLATFORM = os.environ['PLATFORM'])
--if os.environ.has_key('CC'):
-+if 'CC' in os.environ:
- env.Replace(CC = os.environ['CC'])
--if os.environ.has_key('CXX'):
-+if 'CXX' in os.environ:
- env.Replace(CXX = os.environ['CXX'])
--if os.environ.has_key('WINDRES'):
-+if 'WINDRES' in os.environ:
- env.Replace(WINDRES = os.environ['WINDRES'])
--if os.environ.has_key('CFLAGS'):
-+if 'CFLAGS' in os.environ:
- env.Append(CCFLAGS = os.environ['CFLAGS'].split())
--if os.environ.has_key('CXXFLAGS'):
-+if 'CXXFLAGS' in os.environ:
- env.Append(CXXFLAGS = os.environ['CXXFLAGS'].split())
--if os.environ.has_key('CPPFLAGS'):
-+if 'CPPFLAGS' in os.environ:
- env.Append(CPPFLAGS = os.environ['CPPFLAGS'].split())
--if os.environ.has_key('LDFLAGS'):
-+if 'LDFLAGS' in os.environ:
- env.Append(LINKFLAGS = os.environ['LDFLAGS'].split())
--if os.environ.has_key('PKG_CONFIG_PATH'):
-+if 'PKG_CONFIG_PATH' in os.environ:
- env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
--if not os.environ.has_key('PKG_CONFIG_PATH') and env['PLATFORM'] == 'darwin':
-+if 'PKG_CONFIG_PATH' not in os.environ and env['PLATFORM'] == 'darwin':
- env['ENV']['PKG_CONFIG_PATH'] = "/usr/local/lib/pkgconfig:/opt/X11/lib/pkgconfig"
--if os.environ.has_key('PKG_CONFIG_LIBDIR'):
-+if 'PKG_CONFIG_LIBDIR' in os.environ:
- env['ENV']['PKG_CONFIG_LIBDIR'] = os.environ['PKG_CONFIG_LIBDIR']
-
--print "platform: ", env['PLATFORM']
-+print("platform: ", env['PLATFORM'])
-
- # compile with clang
- if env['CLANG']:
-@@ -103,18 +103,18 @@ else:
- assert conf.CheckLibWithHeader('z', 'zlib.h', 'c', 'inflate;', 1), "please install: zlib"
- if env['SDL2']:
- if not conf.CheckLib('SDL2'):
-- print 'Did not find libSDL2 or SDL2.lib, exiting!'
-+ print('Did not find libSDL2 or SDL2.lib, exiting!')
- Exit(1)
- env.Append(CPPDEFINES=["_SDL2"])
- env.ParseConfig('pkg-config sdl2 --cflags --libs')
- else:
- if not conf.CheckLib('SDL'):
-- print 'Did not find libSDL or SDL.lib, exiting!'
-+ print('Did not find libSDL or SDL.lib, exiting!')
- Exit(1)
- env.ParseConfig('sdl-config --cflags --libs')
- if env['GTK']:
- if not conf.CheckLib('gtk-x11-2.0'):
-- print 'Could not find libgtk-2.0, exiting!'
-+ print('Could not find libgtk-2.0, exiting!')
- Exit(1)
- # Add compiler and linker flags from pkg-config
- config_string = 'pkg-config --cflags --libs gtk+-2.0'
-@@ -153,7 +153,7 @@ else:
- env.Append(CCFLAGS = ["-I/usr/include/lua"])
- lua_available = True
- if lua_available == False:
-- print 'Could not find liblua, exiting!'
-+ print('Could not find liblua, exiting!')
- Exit(1)
- else:
- env.Append(CCFLAGS = ["-Isrc/lua/src"])
-@@ -167,7 +167,7 @@ else:
- gd = conf.CheckLib('gd', autoadd=1)
- if gd == 0:
- env['LOGO'] = 0
-- print 'Did not find libgd, you won\'t be able to create a logo screen for your avis.'
-+ print('Did not find libgd, you won\'t be able to create a logo screen for your avis.')
-
- if env['OPENGL'] and conf.CheckLibWithHeader('GL', 'GL/gl.h', 'c', autoadd=1):
- conf.env.Append(CCFLAGS = "-DOPENGL")
-@@ -181,8 +181,8 @@ if sys.byteorder == 'little' or env['PLATFORM'] == 'win32':
- if env['FRAMESKIP']:
- env.Append(CPPDEFINES = ['FRAMESKIP'])
-
--print "base CPPDEFINES:",env['CPPDEFINES']
--print "base CCFLAGS:",env['CCFLAGS']
-+print("base CPPDEFINES:",env['CPPDEFINES'])
-+print("base CCFLAGS:",env['CCFLAGS'])
-
- if env['DEBUG']:
- env.Append(CPPDEFINES=["_DEBUG"], CCFLAGS = ['-g', '-O0'])
-diff --git a/src/SConscript b/src/SConscript
-index 4713e15..2001146 100644
---- a/src/SConscript
-+++ b/src/SConscript
-@@ -33,7 +33,7 @@ else:
- platform_files = SConscript('drivers/sdl/SConscript')
- file_list.append(platform_files)
-
--print env['LINKFLAGS']
-+print(env['LINKFLAGS'])
-
- if env['PLATFORM'] == 'win32':
- fceux = env.Program('fceux.exe', file_list)
diff --git a/games-emulation/fceux/metadata.xml b/games-emulation/fceux/metadata.xml
index 4c416fd6a7a3..87755bab0ade 100644
--- a/games-emulation/fceux/metadata.xml
+++ b/games-emulation/fceux/metadata.xml
@@ -5,9 +5,6 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
- <use>
- <flag name="logo">Enable the ability to add a logo screen when creating AVIs</flag>
- </use>
<upstream>
<remote-id type="github">TASVideos/fceux</remote-id>
<remote-id type="sourceforge">fceultra</remote-id>