summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 10:42:08 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:25:04 +0200
commitad0b66644780ee3c91650c6d3596a88ed2aa7e5a (patch)
treeed68ad2d890db7f34b7a9fc4257b94be57c92855 /games-emulation
parentgames-board/xmille: Drop old (diff)
downloadgentoo-ad0b66644780ee3c91650c6d3596a88ed2aa7e5a.tar.gz
gentoo-ad0b66644780ee3c91650c6d3596a88ed2aa7e5a.tar.bz2
gentoo-ad0b66644780ee3c91650c6d3596a88ed2aa7e5a.zip
games-emulation/advancemame: Version bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/Manifest1
-rw-r--r--games-emulation/advancemame/advancemame-3.7.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 2797a94015b9..d0649f0364a1 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1 +1,2 @@
DIST advancemame-1.2.tar.gz 17508670 BLAKE2B 44b2d549e9ee6bb8d46815c083851b0b25fb6c7eda21a4ac28fe805306965ce5c07b2cfb679a43eebeb9aff4cc34ccfa12e554a008c2d2e70ee59bedc41d15d8 SHA512 6d9cf7ce0553ea6bc60c91bff7d55f282ebd671c5a48ebb25a8b0a41c575b3a8f0446f8f39ca0bccf93493ef28b331d4661987eb1f8adc5bd2c911674d1be583
+DIST advancemame-3.7.tar.gz 25616260 BLAKE2B 455004ff7ce3f7517c6b06767e9d1656bff6b93f822d363cbd42738e0f9ba988c243f600db5f20e24897c27faaf5c458072e2bc9c97cf92803f76299cf3010b8 SHA512 b5af59cdd3cf70dfae0769ed35eb6ce00a6f01d05eefcb687f322420faa2ee5aabf83394249c2ab7f7f1241d3fd09c2f0412666b2dbd27b91e7bc3622f925f74
diff --git a/games-emulation/advancemame/advancemame-3.7.ebuild b/games-emulation/advancemame/advancemame-3.7.ebuild
new file mode 100644
index 000000000000..37773715f8e2
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-3.7.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://www.advancemame.it/"
+SRC_URI="https://github.com/amadvance/advancemame/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fbcon oss truetype"
+
+# sdl is required (bug #158417)
+RDEPEND="
+ app-arch/unzip
+ app-arch/zip
+ dev-libs/expat
+ media-libs/libsdl2
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ truetype? ( media-libs/freetype:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ x86? ( >=dev-lang/nasm-0.98 )
+"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}/${PN}-1.2-pic.patch" \
+ "${FILESDIR}"/${PN}-1.2-verboselog.patch
+
+ sed -i -e 's/"-s"//' configure || die
+
+ use x86 && ln -s $(type -P nasm) "${T}/${CHOST}-nasm"
+ ln -s $(type -P sdl2-config) "${T}/${CHOST}-sdl2-config"
+ use truetype && ln -s $(type -P freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_configure() {
+ # Fix for bug #78030
+ if use ppc; then
+ append-ldflags "-Wl,--relax"
+ fi
+
+ PATH="${PATH}:${T}"
+ econf \
+ --enable-expat \
+ --enable-sdl2 \
+ --disable-sdl \
+ --enable-zlib \
+ --disable-slang \
+ --disable-svgalib \
+ --disable-static \
+ $(use_enable alsa) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable truetype freetype) \
+ $(use_enable x86 asm)
+}
+
+src_compile() {
+ STRIPPROG=true emake
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [[ -L "${f}" ]] ; then
+ dobin "${f}"
+ fi
+ done
+
+ insinto "/usr/share/advance"
+ doins support/event.dat
+ keepdir "/usr/share/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ HTMLDOCS="*.html" einstalldocs
+
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+}