summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-02 07:42:59 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-02 07:43:10 +0100
commite7e66a46b94f8707499ab2c266b3a6ce627cadc5 (patch)
treeccc1f03e37c3b5f2600d7c0ffc6a2873ec5dd151 /games-emulation
parentdev-java/junit-clptr: x86 stable wrt bug #799743 (diff)
downloadgentoo-e7e66a46b94f8707499ab2c266b3a6ce627cadc5.tar.gz
gentoo-e7e66a46b94f8707499ab2c266b3a6ce627cadc5.tar.bz2
gentoo-e7e66a46b94f8707499ab2c266b3a6ce627cadc5.zip
games-emulation/dolphin: add missing headers for musl
Reported-by: ernsteiswuerfel Closes: https://bugs.gentoo.org/799281 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20210506.ebuild2
-rw-r--r--games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch24
2 files changed, 26 insertions, 0 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild b/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
index 2a9debffb0ff..fd44c78fa9e2 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20210506.ebuild
@@ -71,6 +71,8 @@ BDEPEND="
RDEPEND="${RDEPEND}
vulkan? ( media-libs/vulkan-loader )"
+PATCHES=("${FILESDIR}"/${P}-musl.patch)
+
src_prepare() {
cmake_src_prepare
diff --git a/games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch b/games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch
new file mode 100644
index 000000000000..51570151c112
--- /dev/null
+++ b/games-emulation/dolphin/files/dolphin-5.0_p20210506-musl.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/799281
+https://github.com/dolphin-emu/dolphin/commit/7a1922fd8f0f6686188d179732c9757faf2d1b4f.patch
+
+From 7a1922fd8f0f6686188d179732c9757faf2d1b4f Mon Sep 17 00:00:00 2001
+From: thyrc <thyrc@users.noreply.github.com>
+Date: Mon, 14 Jun 2021 10:18:34 +0200
+Subject: [PATCH] Fix includes for musl libc
+
+---
+ Source/Core/Core/MemoryWatcher.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Source/Core/Core/MemoryWatcher.cpp b/Source/Core/Core/MemoryWatcher.cpp
+index 491ecd83150a..13843e2021ca 100644
+--- a/Source/Core/Core/MemoryWatcher.cpp
++++ b/Source/Core/Core/MemoryWatcher.cpp
+@@ -2,6 +2,7 @@
+ // Licensed under GPLv2+
+ // Refer to the license.txt file included.
+
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
+ #include <sstream>