summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaylor C. Richberger <taywee@gmx.com>2021-07-27 21:25:08 -0600
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-28 07:45:46 +0100
commitec76e3439fd84be67bcd5b1e6591ccd24253b0d2 (patch)
tree132604370757d48373d718fd4225f8a736a5a9e3 /games-emulation
parentapp-text/poppler: sparc stable wrt bug #795261 (diff)
downloadgentoo-ec76e3439fd84be67bcd5b1e6591ccd24253b0d2.tar.gz
gentoo-ec76e3439fd84be67bcd5b1e6591ccd24253b0d2.tar.bz2
gentoo-ec76e3439fd84be67bcd5b1e6591ccd24253b0d2.zip
games-emulation/dolphin: enable mGBA support
Closes: https://bugs.gentoo.org/804666 Reported-by: Taylor C. Richberger <taywee@gmx.com> Reviewed-by: Sergei Trofimovich <slyfox@gentoo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b2fd4d445542..fd99d4066165 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -11,7 +11,7 @@ inherit cmake desktop xdg-utils pax-utils plocale
if [[ ${PV} == *9999 ]]
then
EGIT_REPO_URI="https://github.com/dolphin-emu/dolphin"
- EGIT_SUBMODULES=()
+ EGIT_SUBMODULES=( Externals/mGBA/mgba )
inherit git-r3
else
inherit vcs-snapshot
@@ -109,6 +109,9 @@ src_prepare() {
picojson
# No code to detect shared library.
zstd
+
+ # This is a stripped-down mGBA for integrated GBA support
+ mGBA
)
local s
for s in "${KEEP_SOURCES[@]}"; do