summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-01 14:26:55 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-01 14:47:26 +0100
commitf95a7ce851a178321083e06f748f193af61e7d9b (patch)
tree3ab66162747b401a2394e714e683bd0c9b4ecb35 /games-emulation
parentdev-python/PySDL2: New package, needed for games-emu/m64py (diff)
downloadgentoo-f95a7ce851a178321083e06f748f193af61e7d9b.tar.gz
gentoo-f95a7ce851a178321083e06f748f193af61e7d9b.tar.bz2
gentoo-f95a7ce851a178321083e06f748f193af61e7d9b.zip
games-emulation/m64py: Bump to 0.2.4, with unbundled PySDL2
Closes: https://bugs.gentoo.org/626488
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/m64py/Manifest1
-rw-r--r--games-emulation/m64py/m64py-0.2.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/games-emulation/m64py/Manifest b/games-emulation/m64py/Manifest
index 585477afd530..42bc9ce289d5 100644
--- a/games-emulation/m64py/Manifest
+++ b/games-emulation/m64py/Manifest
@@ -1 +1,2 @@
DIST m64py-0.2.3.tar.gz 304241 BLAKE2B efd7e4fc9a75d2b9525ad40e67f92ff56e0e932d96ee4ba51fc128d0fa8fb88a0811efada86af580501803f4f9d9e94aee23d6a50704c2e05078cc511825f347 SHA512 5471d2ce96007c5cb5492f7ba3bc2a8843455dfea811b114c68862fa5c06a636e6dd6a4304e60bf2273377330b0eb01f2dcdc0340d02ec498ae44cdd2ccc01ff
+DIST m64py-0.2.4.tar.gz 209621 BLAKE2B 05fe7044ec096767ae1eb57aad9f326b157d67ea709ca0bb74cdd68ae16a23eb662a2842bef5e038d1b29cbf0a5252669ff54268d1227390f47e8c9029b63e6a SHA512 ab78565466c6dcfe604cdc00b7e63dee2f0f33514dbf4f9115af646b1f6562042516513d054bd5cb489ad89c9d30431e9ce531f8b27925ecb9c6f7b509836348
diff --git a/games-emulation/m64py/m64py-0.2.4.ebuild b/games-emulation/m64py/m64py-0.2.4.ebuild
new file mode 100644
index 000000000000..539d28ed1665
--- /dev/null
+++ b/games-emulation/m64py/m64py-0.2.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="A frontend for Mupen64Plus"
+HOMEPAGE="http://m64py.sourceforge.net/"
+SRC_URI="mirror://sourceforge/m64py/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 public-domain GPL-2 BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,opengl,widgets,${PYTHON_USEDEP}]
+ dev-python/PySDL2[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,video]
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2"
+
+python_prepare_all() {
+ # set the correct search path
+ cat >> src/m64py/platform.py <<-_EOF_
+ SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
+_EOF_
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ local vr
+ for vr in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 0.2.1-r1 ${vr}; then
+ ewarn
+ ewarn "Starting with mupen64plus-2.0-r1, the plugin install path has changed."
+ ewarn "In order for m64py to find mupen64plus, you will either need to set"
+ ewarn "new paths in configuration dialog or remove your configuration file."
+ ewarn "The new paths are:"
+ ewarn
+ ewarn " Library file: /usr/$(get_libdir)/libmupen64plus.so.2.0.0"
+ ewarn " Plugins directory: /usr/$(get_libdir)/mupen64plus"
+ ewarn " Data directory: /usr/share/mupen64plus"
+ fi
+ done
+
+ if ! type -P rar >/dev/null && ! type -P unrar >/dev/null; then
+ elog
+ elog "In order to gain RAR archive support, please install either app-arch/rar"
+ elog "or app-arch/unrar."
+ fi
+
+ if ! type -P 7z >/dev/null \
+ && ! has_version "dev-python/pylzma[${PYTHON_USEDEP}]"; then
+ elog
+ elog "In order to gain 7z archive support, please install either app-arch/p7zip"
+ elog "or dev-python/pylzma."
+ fi
+}