summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-27 15:54:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-27 16:08:37 -0500
commitfe1e9d63e138d4cf1bd4b6ae255c8f70805c9321 (patch)
tree27b30c707c62aaea3480f2deb8eb723b30a68840 /games-emulation
parentapp-shells/autojump: Use mock from unittest (diff)
downloadgentoo-fe1e9d63e138d4cf1bd4b6ae255c8f70805c9321.tar.gz
gentoo-fe1e9d63e138d4cf1bd4b6ae255c8f70805c9321.tar.bz2
gentoo-fe1e9d63e138d4cf1bd4b6ae255c8f70805c9321.zip
games-emulation/pcsx2: fix build with wxGTK[sdl], adjust options
SDL2_API is essentially an unused option, but an old cmake check still use it when it detects wxGTK was built with sdl support. Also sorted options and removed CMAKE_LIBRARY_PATH as it does not install plugins anymore. Thanks-to: Jusef N. Closes: https://github.com/gentoo/gentoo/pull/23989 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 98c547c226ce..f5543f61bed1 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -96,13 +96,12 @@ src_configure() {
-DDISABLE_BUILD_DATE=TRUE
-DDISABLE_PCSX2_WRAPPER=TRUE
-DDISABLE_SETCAP=TRUE
- -DENABLE_TESTS="$(usex test)"
+ -DENABLE_TESTS=$(usex test)
-DPACKAGE_MODE=TRUE
- -DXDG_STD=TRUE
-
- -DCMAKE_LIBRARY_PATH="/usr/$(get_libdir)/${PN}"
+ -DSDL2_API=TRUE # uses SDL2 either way but option is needed if wxGTK[sdl]
-DUSE_SYSTEM_YAML=TRUE
-DUSE_VTUNE=FALSE
+ -DXDG_STD=TRUE
)
setup-wxwidgets