summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-10-31 10:44:54 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 15:19:43 +0200
commitff0791015fac652c4e28fac9ff00dd805a75369b (patch)
tree10f13e3928ef9babfc0e45f2afd6219667111eed /games-emulation
parentapp-cdr/dolphin-plugins-mountiso: Drop 20.12.3 (r0) (diff)
downloadgentoo-ff0791015fac652c4e28fac9ff00dd805a75369b.tar.gz
gentoo-ff0791015fac652c4e28fac9ff00dd805a75369b.tar.bz2
gentoo-ff0791015fac652c4e28fac9ff00dd805a75369b.zip
games-emulation/higan: Version bump to 116_pre20210404
Closes: https://bugs.gentoo.org/709674 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18503 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/higan/Manifest1
-rw-r--r--games-emulation/higan/higan-116_pre20210404.ebuild101
-rw-r--r--games-emulation/higan/metadata.xml6
3 files changed, 107 insertions, 1 deletions
diff --git a/games-emulation/higan/Manifest b/games-emulation/higan/Manifest
index 21f340144cdd..f87f396c26e9 100644
--- a/games-emulation/higan/Manifest
+++ b/games-emulation/higan/Manifest
@@ -1 +1,2 @@
DIST higan-106_p1.tar.bz2 954533 BLAKE2B e7ea44f97f7e2c3ce86b57b853aa59c4372f37185846f8a928ba659b525965aed39f7859721394a776990e53e2f671fc0e7071d17f9397973343d9a7adcf70ac SHA512 f4d8dbfacaa20b948bd382fd0ef48e89cbb21a0569a70b6a4beca6c0a2ba404efc4c28d14bfd3df14d4fd76c763ca1537166bb24d765a8da33423bbea32df4c3
+DIST higan-116_pre20210404.tar.gz 9130899 BLAKE2B bb9830901d7014f9d442f3a3bd9bd82ad791d2ba62a3264cfc187e5d7498a5ec6eae1fff6509f5206d9a21294e2a3ef710fbed5fac3626ecc88c4156bd50f289 SHA512 8ee40d8b9867fe767d5321dc4df3e73039fa39b7ecad2eddb58c3114bcf42b1b2074396ae5c4783ca060057aeb4bca7110101cc44d9608fe7c4d5f561b3f40a5
diff --git a/games-emulation/higan/higan-116_pre20210404.ebuild b/games-emulation/higan/higan-116_pre20210404.ebuild
new file mode 100644
index 000000000000..bf6c718a2f3d
--- /dev/null
+++ b/games-emulation/higan/higan-116_pre20210404.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=9a625c545ca89b094d5c1da40bbfa5d07156a4aa
+
+inherit desktop toolchain-funcs xdg
+
+DESCRIPTION="Multi-system emulator focused on accuracy, preservation, and configurability"
+HOMEPAGE="https://github.com/higan-emu/higan"
+SRC_URI="https://github.com/higan-emu/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa ao +gtk openal +opengl oss +pulseaudio +sdl udev xv"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ openal? ( media-libs/openal )
+ opengl? ( virtual/opengl )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl2[joystick] )
+ udev? ( virtual/udev )
+ xv? ( x11-libs/libXv )
+ gtk? (
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ )
+ !gtk? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ local makeopts=(
+ platform=linux
+ compiler="$(tc-getCXX)"
+ hiro="$(usex gtk gtk3 qt5)"
+ )
+
+ local drivers=(
+ video.xshm
+ input.xlib
+ $(usex alsa audio.alsa "")
+ $(usex ao audio.ao "")
+ $(usex openal audio.openal "")
+ $(usex opengl "video.glx video.glx2" "")
+ $(usex oss audio.oss "")
+ $(usex pulseaudio "audio.pulseaudio audio.pulseaudiosimple" "")
+ $(usex sdl input.sdl "")
+ $(usex udev input.udev "")
+ $(usex xv video.xvideo "")
+ )
+
+ local coreopts=(
+ cores="cv fc gb gba md ms msx ngp pce sfc sg ws"
+ ruby="${drivers[*]}"
+ build=performance
+ local=false
+ )
+
+ # Make higan
+ emake "${makeopts[@]}" "${coreopts[@]}" -C higan-ui
+
+ # Make icarus
+ emake "${makeopts[@]}" -C icarus
+}
+
+src_install() {
+ # Install higan
+ dobin higan-ui/out/higan
+
+ insinto "/usr/share/${P}"
+ doins -r higan/System
+
+ domenu higan-ui/resource/higan.desktop
+ doicon -s 256 higan-ui/resource/higan.png
+
+ doins -r extras
+
+ # Install icarus
+ dobin icarus/out/icarus
+
+ domenu icarus/resource/icarus.desktop
+ doicon -s scalable icarus/resource/icarus.svg
+
+ insinto "/usr/share/${P}/Database"
+ doins -r icarus/Database
+ insinto "/usr/share/${P}/Firmware"
+ doins -r icarus/Firmware
+}
diff --git a/games-emulation/higan/metadata.xml b/games-emulation/higan/metadata.xml
index 5bef912000c6..b9316f15fc58 100644
--- a/games-emulation/higan/metadata.xml
+++ b/games-emulation/higan/metadata.xml
@@ -7,6 +7,10 @@
</maintainer>
<use>
<flag name="icarus">Build icarus library manager</flag>
- <flag name="udev">Enable udev based input</flag>
+ <flag name="gtk">Use GTK3 (Qt5 if disabled) user interface backend</flag>
</use>
+ <upstream>
+ <bugs-to>https://github.com/higan-emu/higan/issues</bugs-to>
+ <remote-id type="github">higan-emu/higan</remote-id>
+ </upstream>
</pkgmetadata>