summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-09-07 23:37:58 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-09-07 23:39:11 +0100
commit83b6c7da77061484a32bab7a95da5f7ecc67c996 (patch)
tree488e183ca526cda7899bdd51d0abb6f4a26fdf5b /games-engines/box2d/box2d-2.1.2.ebuild
parentgnome-extra/evolution-ews: bump to 3.32.2 (diff)
downloadgentoo-83b6c7da77061484a32bab7a95da5f7ecc67c996.tar.gz
gentoo-83b6c7da77061484a32bab7a95da5f7ecc67c996.tar.bz2
gentoo-83b6c7da77061484a32bab7a95da5f7ecc67c996.zip
games-engines/box2d: New package
I had hoped to use this for Shovel Knight but it needs a custom version. Adding it anyway. Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/box2d/box2d-2.1.2.ebuild')
-rw-r--r--games-engines/box2d/box2d-2.1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-engines/box2d/box2d-2.1.2.ebuild b/games-engines/box2d/box2d-2.1.2.ebuild
new file mode 100644
index 000000000000..953853c49214
--- /dev/null
+++ b/games-engines/box2d/box2d-2.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib
+
+MY_PN="Box2D"
+DESCRIPTION="A C++ engine for simulating rigid bodies in 2D games"
+HOMEPAGE="https://box2d.org/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${MY_PN}_v${PV}.zip"
+LICENSE="ZLIB"
+SLOT="$(ver_cut 1-2).0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}_v${PV}/${MY_PN}"
+
+src_prepare() {
+ # This version supports CMake but upstream has dropped it since this
+ # release. They now use Premake but this Meson file is actually
+ # simpler! Installation is manual but that's true for Premake too.
+ cat > meson.build <<EOF || die
+project('${MY_PN}', 'cpp')
+shared_library(
+ '${MY_PN}',
+ $(find ${MY_PN} -name "*.cpp" -printf "'%p', ")
+ soversion: '${SLOT}', install : true
+)
+EOF
+
+ default
+}
+
+src_install() {
+ dodoc Readme.txt
+ dolib.so "${BUILD_DIR}"/lib${MY_PN}$(get_libname ${SLOT})
+
+ local FILE
+ for FILE in $(find ${MY_PN} -name *.h); do
+ insinto "/usr/include/${MY_PN}-${SLOT}/${FILE%/*}"
+ doins "${FILE}"
+ done
+}