summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/frotz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/frotz')
-rw-r--r--games-engines/frotz/Manifest1
-rw-r--r--games-engines/frotz/files/frotz-2.43-glibc2.10.patch29
-rw-r--r--games-engines/frotz/files/frotz-2.43-ldflags.patch20
-rw-r--r--games-engines/frotz/frotz-2.43.ebuild51
-rw-r--r--games-engines/frotz/metadata.xml5
5 files changed, 106 insertions, 0 deletions
diff --git a/games-engines/frotz/Manifest b/games-engines/frotz/Manifest
new file mode 100644
index 000000000000..486870574179
--- /dev/null
+++ b/games-engines/frotz/Manifest
@@ -0,0 +1 @@
+DIST frotz-2.43.tar.gz 160771 SHA256 f831eae9182e4a1407a34cb1098a4f5ad5ad6c6632e34eed734b9601a06a764b SHA512 654f2ca2d1a625df8f88b5629e09a873668cea42688acdf154636b066b94fc9d70b7f45acb33a71d234c19b59c394c63aee38d6224245b3b329210e6b4a58409 WHIRLPOOL af75842ed8693895d564cbaa4fa3d7b095a4470101728179a7d8659876e1043d98274330d2f7efbe0fd1443ea68ad2fcb49efe4b3e6a6dede6f3e9f4e574de5c
diff --git a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
new file mode 100644
index 000000000000..71760cc8fa46
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
@@ -0,0 +1,29 @@
+--- src/dumb/dumb_input.c
++++ src/dumb/dumb_input.c
+@@ -79,7 +79,7 @@
+ /* Read one line, including the newline, into s. Safely avoids buffer
+ * overruns (but that's kind of pointless because there are several
+ * other places where I'm not so careful). */
+-static void getline(char *s)
++static void get_line(char *s)
+ {
+ int c;
+ char *p = s;
+@@ -203,7 +203,7 @@
+ fputs(prompt, stdout);
+ else
+ dumb_show_prompt(show_cursor, (timeout ? "tTD" : ")>}")[type]);
+- getline(s);
++ get_line(s);
+ if ((s[0] != '\\') || ((s[1] != '\0') && !islower(s[1]))) {
+ /* Is not a command line. */
+ translate_special_chars(s);
+@@ -265,7 +265,7 @@
+ if (!*current_page)
+ break;
+ printf("HELP: Type <return> for more, or q <return> to stop: ");
+- getline(s);
++ get_line(s);
+ if (!strcmp(s, "q\n"))
+ break;
+ }
diff --git a/games-engines/frotz/files/frotz-2.43-ldflags.patch b/games-engines/frotz/files/frotz-2.43-ldflags.patch
new file mode 100644
index 000000000000..16a0df362edd
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.43-ldflags.patch
@@ -0,0 +1,20 @@
+--- Makefile.old 2010-10-04 14:13:37.000000000 +0200
++++ Makefile 2010-10-04 14:14:06.000000000 +0200
+@@ -162,7 +162,7 @@
+ $(NAME): $(NAME)-curses
+
+ $(NAME)-curses: soundcard.h $(COMMON_TARGET) $(CURSES_TARGET)
+- $(CC) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
++ $(CC) $(LDFLAGS) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
+ $(SOUND_LIB)
+
+ all: $(NAME) d$(NAME)
+@@ -170,7 +170,7 @@
+ dumb: $(NAME)-dumb
+ d$(NAME): $(NAME)-dumb
+ $(NAME)-dumb: $(COMMON_TARGET) $(DUMB_TARGET)
+- $(CC) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
++ $(CC) $(LDFLAGS) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
+ $(DUMB_TARGET) $(LIB)
+
+ .SUFFIXES:
diff --git a/games-engines/frotz/frotz-2.43.ebuild b/games-engines/frotz/frotz-2.43.ebuild
new file mode 100644
index 000000000000..9775c754821e
--- /dev/null
+++ b/games-engines/frotz/frotz-2.43.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Curses based interpreter for Z-code based text games"
+HOMEPAGE="http://frotz.sourceforge.net/"
+SRC_URI="http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="alsa oss"
+
+DEPEND="sys-libs/ncurses
+ alsa? ( oss? ( media-libs/alsa-oss ) )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC /d' \
+ Makefile \
+ || die
+ epatch \
+ "${FILESDIR}"/${P}-glibc2.10.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ local OPTS="CONFIG_DIR=${GAMES_SYSCONFDIR}"
+ use oss && OPTS="${OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
+ emake ${OPTS} all
+}
+
+src_install () {
+ dogamesbin {d,}frotz
+ doman doc/*.6
+ dodoc AUTHORS BUGS ChangeLog HOW_TO_PLAY README TODO \
+ doc/{frotz.conf-big,frotz.conf-small}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Global config file can be installed in ${GAMES_SYSCONFDIR}/frotz.conf"
+ elog "Sample config files are in /usr/share/doc/${PF}"
+ echo
+}
diff --git a/games-engines/frotz/metadata.xml b/games-engines/frotz/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-engines/frotz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>