summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-10-13 18:34:36 +0200
committerMarek Szuba <marecki@gentoo.org>2020-10-13 18:47:57 +0200
commita8dce7e04326898caa8ed79e49516c1b9ebaac9c (patch)
treef7daff9104ecb7d9d9da7488d76e1c79689bea38 /games-engines/love
parentgames-engines/love: remove old (diff)
downloadgentoo-a8dce7e04326898caa8ed79e49516c1b9ebaac9c.tar.gz
gentoo-a8dce7e04326898caa8ed79e49516c1b9ebaac9c.tar.bz2
gentoo-a8dce7e04326898caa8ed79e49516c1b9ebaac9c.zip
games-engines/love: fix compilation error in 0.7 and 0.8
Closes: https://bugs.gentoo.org/672558 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-engines/love')
-rw-r--r--games-engines/love/files/love-0.7.2-opengl_glext_prototypes.patch19
-rw-r--r--games-engines/love/files/love-0.8.0-opengl_glext_prototypes.patch54
-rw-r--r--games-engines/love/love-0.7.2-r2.ebuild7
-rw-r--r--games-engines/love/love-0.8.0-r2.ebuild7
4 files changed, 83 insertions, 4 deletions
diff --git a/games-engines/love/files/love-0.7.2-opengl_glext_prototypes.patch b/games-engines/love/files/love-0.7.2-opengl_glext_prototypes.patch
new file mode 100644
index 000000000000..887f61ddd560
--- /dev/null
+++ b/games-engines/love/files/love-0.7.2-opengl_glext_prototypes.patch
@@ -0,0 +1,19 @@
+diff -ur love-HEAD.orig/src/modules/graphics/opengl/Framebuffer.cpp love-HEAD/src/modules/graphics/opengl/Framebuffer.cpp
+--- love-HEAD.orig/src/modules/graphics/opengl/Framebuffer.cpp 2019-06-03 01:15:56.600016765 +0200
++++ love-HEAD/src/modules/graphics/opengl/Framebuffer.cpp 2019-06-03 01:16:16.737916762 +0200
+@@ -1,3 +1,4 @@
++#define GL_GLEXT_PROTOTYPES
+ #include "Framebuffer.h"
+ #include <common/Matrix.h>
+
+diff -ur love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp
+--- love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp 2019-06-03 01:15:56.601016760 +0200
++++ love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp 2019-06-03 01:16:31.007845896 +0200
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "SpriteBatch.h"
+
+ // STD
diff --git a/games-engines/love/files/love-0.8.0-opengl_glext_prototypes.patch b/games-engines/love/files/love-0.8.0-opengl_glext_prototypes.patch
new file mode 100644
index 000000000000..300bc3383433
--- /dev/null
+++ b/games-engines/love/files/love-0.8.0-opengl_glext_prototypes.patch
@@ -0,0 +1,54 @@
+diff -ur love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp
+--- love-HEAD.orig/src/modules/graphics/opengl/SpriteBatch.cpp
++++ love-HEAD/src/modules/graphics/opengl/SpriteBatch.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "SpriteBatch.h"
+
+ // STD
+--- a/src/modules/graphics/opengl/VertexBuffer.cpp
++++ b/src/modules/graphics/opengl/VertexBuffer.cpp
+@@ -18,6 +18,9 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
++#include "SpriteBatch.h"
++
+ #include "VertexBuffer.h"
+
+ #include "common/Exception.h"
+--- a/src/modules/graphics/opengl/Graphics.cpp
++++ b/src/modules/graphics/opengl/Graphics.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include <common/config.h>
+ #include <common/math.h>
+ #include <common/Vector.h>
+--- a/src/modules/graphics/opengl/PixelEffect.cpp
++++ b/src/modules/graphics/opengl/PixelEffect.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "PixelEffect.h"
+ #include "GLee.h"
+
+
+--- a/src/modules/graphics/opengl/Canvas.cpp
++++ b/src/modules/graphics/opengl/Canvas.cpp
+@@ -18,6 +18,7 @@
+ * 3. This notice may not be removed or altered from any source distribution.
+ **/
+
++#define GL_GLEXT_PROTOTYPES
+ #include "Canvas.h"
+ #include "Graphics.h"
+ #include <common/Matrix.h>
diff --git a/games-engines/love/love-0.7.2-r2.ebuild b/games-engines/love/love-0.7.2-r2.ebuild
index e29f78d0863e..5cc2816ee04b 100644
--- a/games-engines/love/love-0.7.2-r2.ebuild
+++ b/games-engines/love/love-0.7.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,7 +31,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-HEAD"
-PATCHES=( "${FILESDIR}"/${PN}-0.8.0-freetype2.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.2-opengl_glext_prototypes.patch
+ "${FILESDIR}"/${PN}-0.8.0-freetype2.patch
+)
src_install() {
DOCS="readme.txt changes.txt" \
diff --git a/games-engines/love/love-0.8.0-r2.ebuild b/games-engines/love/love-0.8.0-r2.ebuild
index 6349e6228b72..9d807e1333df 100644
--- a/games-engines/love/love-0.8.0-r2.ebuild
+++ b/games-engines/love/love-0.8.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,7 +29,10 @@ DEPEND="${RDEPEND}
media-libs/tiff:0
"
-PATCHES=( "${FILESDIR}"/${P}-freetype2.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-freetype2.patch
+ "${FILESDIR}"/${PN}-0.8.0-opengl_glext_prototypes.patch
+)
src_install() {
DOCS="readme.md changes.txt" \