summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2022-02-03 17:21:12 +0900
committerJames Le Cuirot <chewi@gentoo.org>2022-02-03 09:11:53 +0000
commit33ce6ae80b24b231e526d388109a780dd84ca202 (patch)
tree4dadbb7c1f88f737f3f44afee4c295d0f94b4a9f /games-engines/odamex
parentapp-editors/gedit-plugins: fix build with meson 0.61 (diff)
downloadgentoo-33ce6ae80b24b231e526d388109a780dd84ca202.tar.gz
gentoo-33ce6ae80b24b231e526d388109a780dd84ca202.tar.bz2
gentoo-33ce6ae80b24b231e526d388109a780dd84ca202.zip
games-engines/odamex: Disable find_package(x11) only for client
Closes: https://bugs.gentoo.org/832449 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24063 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/odamex')
-rw-r--r--games-engines/odamex/odamex-0.9.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-engines/odamex/odamex-0.9.5.ebuild b/games-engines/odamex/odamex-0.9.5.ebuild
index 62d3c471ea58..56b4b013e2cf 100644
--- a/games-engines/odamex/odamex-0.9.5.ebuild
+++ b/games-engines/odamex/odamex-0.9.5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
WX_GTK_VER="3.0-gtk3"
inherit cmake desktop prefix wxwidgets xdg
@@ -49,7 +49,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X)
-DUSE_INTERNAL_LIBS=0
-DBUILD_CLIENT=$(usex client)
-DBUILD_LAUNCHER=$(usex odalaunch)
@@ -59,6 +58,7 @@ src_configure() {
-DENABLE_PORTMIDI=$(usex portmidi)
-DUSE_MINIUPNP=$(usex upnp)
)
+ use client && mycmakeargs+=(-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X))
cmake_src_configure
}