summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /games-engines/odamex
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-engines/odamex')
-rw-r--r--games-engines/odamex/odamex-0.8.1-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-engines/odamex/odamex-0.8.1-r1.ebuild b/games-engines/odamex/odamex-0.8.1-r1.ebuild
index c823dedd980d..43af64e77527 100644
--- a/games-engines/odamex/odamex-0.8.1-r1.ebuild
+++ b/games-engines/odamex/odamex-0.8.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit cmake-utils desktop prefix wxwidgets xdg
+inherit cmake desktop prefix wxwidgets xdg
DESCRIPTION="Online multiplayer free software engine for DOOM"
HOMEPAGE="https://odamex.net/"
@@ -44,7 +44,7 @@ src_prepare() {
use odalaunch && setup-wxwidgets
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -57,11 +57,11 @@ src_configure() {
-DUSE_MINIUPNP=$(usex upnp)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
# Build odamex.wad
cd wad || die "cd failed"
@@ -79,5 +79,5 @@ src_install() {
fi
fi
- cmake-utils_src_install
+ cmake_src_install
}