summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-11-03 15:17:40 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-11-05 06:45:48 +0200
commit72a90462453f12ac77bb044cdf608784c121a9db (patch)
treefa40e2f9052019257406e521781b16479e21dc2e /games-engines
parentgames-misc/exult-sound: update ebuild (diff)
downloadgentoo-72a90462453f12ac77bb044cdf608784c121a9db.tar.gz
gentoo-72a90462453f12ac77bb044cdf608784c121a9db.tar.bz2
gentoo-72a90462453f12ac77bb044cdf608784c121a9db.zip
games-engines/exult: version 1.6
Stable release of package. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/exult/Manifest1
-rw-r--r--games-engines/exult/exult-1.6.ebuild51
-rw-r--r--games-engines/exult/metadata.xml2
3 files changed, 54 insertions, 0 deletions
diff --git a/games-engines/exult/Manifest b/games-engines/exult/Manifest
new file mode 100644
index 000000000000..89066ec8df51
--- /dev/null
+++ b/games-engines/exult/Manifest
@@ -0,0 +1 @@
+DIST exult-1.6.tar.gz 7906968 BLAKE2B f58b009bf82c5120a7ce588cbc5d2b282b92d7e8d08fb3e6119436de178ebd8af1d9a10e4ba660038aac9b87f0ced3fbbdbc5f39a3b3e17fee36b295d7df2603 SHA512 e786ccc11d3fc1b0747c0c620b51152d09f5157ca1e458a5aecc5e66c91e3222b6ba61311149bd6be83e20d339ea1d6d47640f89cc1750a9720549278a33e1b2
diff --git a/games-engines/exult/exult-1.6.ebuild b/games-engines/exult/exult-1.6.ebuild
new file mode 100644
index 000000000000..98d89565e660
--- /dev/null
+++ b/games-engines/exult/exult-1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
+HOMEPAGE="http://exult.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/exult-all-versions/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fluidsynth opengl +sdl2 timidity tools"
+
+DEPEND="
+ games-misc/exult-sound
+ >=media-libs/libpng-1.6:0=
+ media-libs/libvorbis
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth )
+ opengl? ( virtual/opengl )
+ sdl2? ( media-libs/libsdl2[sound,video,X] )
+ !sdl2? ( media-libs/libsdl[sound,video,X] )
+ timidity? ( >=media-sound/timidity++-2 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ AUTHORS ChangeLog FAQ NEWS README README.1ST
+)
+
+src_configure() {
+ econf \
+ --enable-mods \
+ --enable-zip-support \
+ --with-desktopdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --with-sdl=$(usex sdl2 sdl2 sdl12) \
+ $(use_enable alsa) \
+ $(use_enable fluidsynth) \
+ $(use_enable opengl) \
+ $(use_enable timidity timidity-midi) \
+ $(use_enable tools)
+}
+
+pkg_postinst() {
+ elog "You *must* have the original Ultima7 The Black Gate and/or"
+ elog "The Serpent Isle installed."
+ elog "See documentation in /usr/share/doc/${PF} for information."
+}
diff --git a/games-engines/exult/metadata.xml b/games-engines/exult/metadata.xml
index a676c5e60d97..3a588d836e61 100644
--- a/games-engines/exult/metadata.xml
+++ b/games-engines/exult/metadata.xml
@@ -10,6 +10,8 @@
<remote-id type="github">exult/exult</remote-id>
</upstream>
<use>
+ <flag name="fluidsynth">Compile with support for FluidSynth</flag>
<flag name="sdl2">Use libsdl2 instead of libsdl</flag>
+ <flag name="tools">Enable tools</flag>
</use>
</pkgmetadata>