summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2022-11-09 14:08:54 +0300
committerIonen Wolkens <ionen@gentoo.org>2022-11-09 21:52:14 -0500
commitca274de84dd6dfaa2dc71dcb30ebc50fdab9e11e (patch)
treec392ea4dc2b0f5045ae2a2adb6f8dc7ecdcd6b57 /games-engines
parentgames-engines/exult: Keyword 1.6 ppc64, #850493 (diff)
downloadgentoo-ca274de84dd6dfaa2dc71dcb30ebc50fdab9e11e.tar.gz
gentoo-ca274de84dd6dfaa2dc71dcb30ebc50fdab9e11e.tar.bz2
gentoo-ca274de84dd6dfaa2dc71dcb30ebc50fdab9e11e.zip
games-engines/exult: add 1.8
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28200 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/exult/Manifest1
-rw-r--r--games-engines/exult/exult-1.8.ebuild56
-rw-r--r--games-engines/exult/metadata.xml2
3 files changed, 58 insertions, 1 deletions
diff --git a/games-engines/exult/Manifest b/games-engines/exult/Manifest
index 89066ec8df51..6f8438c5319a 100644
--- a/games-engines/exult/Manifest
+++ b/games-engines/exult/Manifest
@@ -1 +1,2 @@
DIST exult-1.6.tar.gz 7906968 BLAKE2B f58b009bf82c5120a7ce588cbc5d2b282b92d7e8d08fb3e6119436de178ebd8af1d9a10e4ba660038aac9b87f0ced3fbbdbc5f39a3b3e17fee36b295d7df2603 SHA512 e786ccc11d3fc1b0747c0c620b51152d09f5157ca1e458a5aecc5e66c91e3222b6ba61311149bd6be83e20d339ea1d6d47640f89cc1750a9720549278a33e1b2
+DIST exult-1.8.tar.gz 19104130 BLAKE2B 56e127d95d3a948b7c52ca3439f8a84691728817c855b46580a8baf21ad0b8f663d5f9fb2fb855d73baa1d3cc29181d001adae1a978c75a7dfa598879b559ab4 SHA512 5422f70c00a1d5ff0606cb7613b891abda430872c50b1058999085c7df08360fd55d5bdf95cbff09616cf3b11e51dce4b11c7322c3db9a8756946e5854ef0fde
diff --git a/games-engines/exult/exult-1.8.ebuild b/games-engines/exult/exult-1.8.ebuild
new file mode 100644
index 000000000000..8e0e2b0a48b2
--- /dev/null
+++ b/games-engines/exult/exult-1.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
+HOMEPAGE="http://exult.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/exult-all-versions/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="alsa fluidsynth timidity tools"
+
+DEPEND="
+ games-misc/exult-sound
+ >=media-libs/libpng-1.6:0=
+ media-libs/libvorbis
+ sys-libs/zlib:=
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth )
+ media-libs/libsdl2[sound,video,X]
+ timidity? ( >=media-sound/timidity++-2 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ AUTHORS ChangeLog FAQ NEWS README
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-zip-support \
+ --with-desktopdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ $(use_enable alsa) \
+ $(use_enable fluidsynth) \
+ $(use_enable timidity timidity-midi) \
+ $(use_enable tools) \
+ $(use_enable tools compiler) \
+ $(use_enable tools mods)
+}
+
+pkg_postinst() {
+ elog "You *must* have the original Ultima7 The Black Gate and/or"
+ elog "The Serpent Isle installed."
+ elog "See documentation in /usr/share/doc/${PF} for information."
+}
diff --git a/games-engines/exult/metadata.xml b/games-engines/exult/metadata.xml
index dfaf409414b7..6351a584ce67 100644
--- a/games-engines/exult/metadata.xml
+++ b/games-engines/exult/metadata.xml
@@ -12,6 +12,6 @@
<use>
<flag name="fluidsynth">Compile with support for FluidSynth</flag>
<flag name="sdl2">Use libsdl2 instead of libsdl</flag>
- <flag name="tools">Enable tools</flag>
+ <flag name="tools">Enable tools, usercode compiler and mods support</flag>
</use>
</pkgmetadata>