summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-12-15 00:11:00 +0100
committerJeroen Roovers <jer@gentoo.org>2017-12-15 00:11:18 +0100
commitf3ad06992697a7d660938271f2b30c0f29751f37 (patch)
treebf50a405f8d850c938871dd0629227481052c8d5 /games-engines
parentgnome-extra/nautilus-tracker-tags: amd64 stable wrt bug #630738 (diff)
downloadgentoo-f3ad06992697a7d660938271f2b30c0f29751f37.tar.gz
gentoo-f3ad06992697a7d660938271f2b30c0f29751f37.tar.bz2
gentoo-f3ad06992697a7d660938271f2b30c0f29751f37.zip
games-engines/exult: Switch to Github repo (maybe bug #640700).
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/exult/exult-9999.ebuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/games-engines/exult/exult-9999.ebuild b/games-engines/exult/exult-9999.ebuild
index 81e6b1ed1572..4efc34a2e5dd 100644
--- a/games-engines/exult/exult-9999.ebuild
+++ b/games-engines/exult/exult-9999.ebuild
@@ -1,38 +1,41 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-ESVN_REPO_URI="https://svn.code.sf.net/p/exult/code/exult/trunk/"
-inherit autotools multilib eutils subversion games
+EAPI=6
+inherit autotools multilib eutils git-r3
DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
HOMEPAGE="http://exult.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/exult/exult"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="timidity zlib"
-DEPEND=">=media-libs/libpng-1.2.43-r2:0
+DEPEND="
+ >=media-libs/libpng-1.2.43-r2:0
games-misc/exult-sound
media-libs/libsdl[sound,video,X]
timidity? ( >=media-sound/timidity++-2 )
- zlib? ( sys-libs/zlib )"
-RDEPEND=${DEPEND}
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="
+ ${DEPEND}
+"
S=${WORKDIR}/${P/_/}
-
-src_unpack() {
- subversion_src_unpack
-}
+DOCS=(
+ AUTHORS ChangeLog FAQ NEWS README README.1ST
+)
src_prepare() {
- subversion_src_prepare
+ default
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
--x-libraries="/usr/$(get_libdir)" \
--disable-tools \
--disable-opengl \
@@ -43,16 +46,7 @@ src_configure() {
$(use_enable zlib zip-support)
}
-src_install() {
- DOCS="AUTHORS ChangeLog NEWS FAQ README README.1ST" \
- default
- # no need for this directory for just playing the game
- #rm -rf "${D}${GAMES_DATADIR}/${PN}/estudio"
- prepgamesdirs
-}
-
pkg_postinst() {
- games_pkg_postinst
elog "You *must* have the original Ultima7 The Black Gate and/or"
elog "The Serpent Isle installed."
elog "See documentation in /usr/share/doc/${PF} for information."