summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/doom3-data/doom3-data-1.1.1282-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/doom3-data/doom3-data-1.1.1282-r1.ebuild')
-rw-r--r--games-fps/doom3-data/doom3-data-1.1.1282-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-fps/doom3-data/doom3-data-1.1.1282-r1.ebuild b/games-fps/doom3-data/doom3-data-1.1.1282-r1.ebuild
new file mode 100644
index 000000000000..387a7fce5681
--- /dev/null
+++ b/games-fps/doom3-data/doom3-data-1.1.1282-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils cdrom games
+
+DESCRIPTION="Doom 3 - data portion"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI=""
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+RDEPEND="games-fps/doom3"
+
+S=${WORKDIR}
+
+src_install() {
+ cdrom_get_cds \
+ Setup/Data/base/pak002.pk4 \
+ Setup/Data/base/pak000.pk4 \
+ Setup/Data/base/pak003.pk4
+
+ insinto "${GAMES_PREFIX_OPT}"/doom3/base
+
+ einfo "Copying files from CD 1..."
+ doins "${CDROM_ROOT}"/Setup/Data/base/pak002.pk4 \
+ || die "doins pak002.pk4 failed"
+
+ cdrom_load_next_cd
+ einfo "Copying files from CD 2..."
+ doins "${CDROM_ROOT}"/Setup/Data/base/pak00{0,1}.pk4 \
+ || die "doins pak00{0,1}.pk4 failed"
+
+ cdrom_load_next_cd
+ einfo "Copying files from CD 3..."
+ doins "${CDROM_ROOT}"/Setup/Data/base/pak00{3,4}.pk4 \
+ || die "doins pak00{3,4}.pk4 failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-fps/doom3 to play the game."
+}