summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/doom3-mitm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/doom3-mitm')
-rw-r--r--games-fps/doom3-mitm/Manifest2
-rw-r--r--games-fps/doom3-mitm/doom3-mitm-20070129.ebuild46
-rw-r--r--games-fps/doom3-mitm/metadata.xml5
3 files changed, 53 insertions, 0 deletions
diff --git a/games-fps/doom3-mitm/Manifest b/games-fps/doom3-mitm/Manifest
new file mode 100644
index 000000000000..4dbc77b42c1f
--- /dev/null
+++ b/games-fps/doom3-mitm/Manifest
@@ -0,0 +1,2 @@
+DIST mitm5.zip 33650739 SHA256 e514c37cc8efc19cac8dc9b55ffae7c98f41aecd6855d3ba8206768ef6167f9d
+DIST mitm_4.zip 136302315 SHA256 a93b65ccb92f3839e9824d00a439e67ecf8c643e1b1d15789b08070d47fa7938
diff --git a/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild b/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild
new file mode 100644
index 000000000000..1d0523ce7e94
--- /dev/null
+++ b/games-fps/doom3-mitm/doom3-mitm-20070129.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="Single player maps"
+MOD_NAME="Make it to Morning"
+
+inherit eutils games games-mods
+
+HOMEPAGE="http://www.makeittomorning.co.uk/"
+SRC_URI="http://www.doomwadstation.com/doom3/maps/Morning/mitm_4.zip
+ http://www.doomwadstation.com/doom3/maps/Morning/mitm5.zip"
+
+LICENSE="all-rights-reserved"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="games-fps/doom3-roe
+ games-fps/doom3[opengl,roe]"
+
+src_unpack() {
+ mkdir mitm
+ cd mitm
+ unpack ${A}
+}
+
+src_prepare() {
+ cd mitm
+ mv -f MITM*.txt mitm.txt || die
+ mv -f Mitm5*.txt mitm5.txt || die
+}
+
+src_install() {
+ games_make_wrapper ${PN} \
+ "doom3 +set fs_game_base d3xp +set fs_game mitm +map mitm"
+ make_desktop_entry ${PN} "Doom 3 - ${MOD_NAME} (1)" doom3
+ local i
+ for i in {2..5} ; do
+ games_make_wrapper ${PN}${i} \
+ "doom3 +set fs_game_base d3xp +set fs_game mitm +map mitm${i}"
+ make_desktop_entry ${PN}${i} "Doom 3 - ${MOD_NAME} (${i})" doom3
+ done
+ games-mods_src_install
+}
diff --git a/games-fps/doom3-mitm/metadata.xml b/games-fps/doom3-mitm/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/doom3-mitm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>