summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/doom3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/doom3')
-rw-r--r--games-fps/doom3/Manifest2
-rw-r--r--games-fps/doom3/doom3-1.3.1304-r1.ebuild100
-rw-r--r--games-fps/doom3/metadata.xml17
3 files changed, 119 insertions, 0 deletions
diff --git a/games-fps/doom3/Manifest b/games-fps/doom3/Manifest
new file mode 100644
index 000000000000..a9d7af90f43e
--- /dev/null
+++ b/games-fps/doom3/Manifest
@@ -0,0 +1,2 @@
+DIST doom3-linux-1.3.1.1304.x86.run 21145838 SHA256 2f90dff20f2d3c0c47f17b3d6d45c4f0e7d27b986bf6084f21b85180cd1e03b4 SHA512 f2a42478d84a6242a7982d1acd726b746596b7a13147acbd920d618223d6f52ab4c49aa7d7f07067674da2881372a181396a0bdd476e3956fb702c76eebb0d02 WHIRLPOOL e80d54176763c37ba21750dbd57cb02beec8cf3fe7d90916ee4024541966b14e7919fa41624dc9fabb44eb824cabcc862fefdf3e58316302a01042d5ee443382
+DIST doom3.png 6502 SHA256 c9a701498a7b0f923182bf9f11aac8d2193026e509ae3643a5bc118b1a458c6b SHA512 9a2b3831babbf3fa0d354e1a4a779c972676edbcc0b287de9b9f3eb830e0a00d557ba9645fbf0e58e07d5705efb0ef2b7ab96cd92493e2a0afc30c8842c0043b WHIRLPOOL e568cdcf3ea510b9865a4c1f1577713c6a63954a22e572311a321c8c73cf70ca68b76134d45a9f1c77e2d6b464ec29e098b7fe39ce1eb38889f83fc3c9bfc05f
diff --git a/games-fps/doom3/doom3-1.3.1304-r1.ebuild b/games-fps/doom3/doom3-1.3.1304-r1.ebuild
new file mode 100644
index 000000000000..65b8bbed0f8d
--- /dev/null
+++ b/games-fps/doom3/doom3-1.3.1304-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PV="1.3.1.1304"
+
+DESCRIPTION="3rd installment of the classic iD 3D first-person shooter"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI="mirror://idsoftware/doom3/linux/doom3-linux-${MY_PV}.x86.run
+ http://zerowing.idsoftware.com/linux/${PN}.png"
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall dedicated roe"
+RESTRICT="strip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ !dedicated? (
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ )
+ cdinstall? (
+ >=games-fps/doom3-data-1.1.1282-r1
+ roe? ( games-fps/doom3-roe ) )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_TEXTRELS="${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbsv.so
+ ${dir:1}/pb/pbags.so"
+
+QA_EXECSTACK="${dir:1}/doom.x86
+ ${dir:1}/doomded.x86"
+
+pkg_pretend() {
+ if use dedicated; then
+ ewarn "${CATEGORY}/${PN}[dedicated] will only install the dedicated game server"
+ fi
+}
+
+src_unpack() {
+ unpack_makeself ${PN}-linux-${MY_PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ doins License.txt CHANGES README version.info ${PN}.png
+ doins -r base d3xp pb
+
+ exeinto "${dir}"
+ doexe openurl.sh bin/Linux/x86/doomded.x86
+ if ! use dedicated; then
+ doexe bin/Linux/x86/doom.x86
+
+ games_make_wrapper ${PN} ./doom.x86 "${dir}" "${dir}"
+ doicon "${DISTDIR}"/${PN}.png || die "doicon"
+ make_desktop_entry ${PN} "Doom III"
+ fi
+ games_make_wrapper ${PN}-ded ./doomded.x86 "${dir}" "${dir}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ elog "You need to copy pak000.pk4, pak001.pk4, pak002.pk4, pak003.pk4, and"
+ elog "pak004.pk4 from either your installation media or your hard drive to"
+ elog "${dir}/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
+ if use roe ; then
+ echo
+ elog "To use the Resurrection of Evil expansion pack, you also need to copy"
+ elog "pak000.pk4 to ${dir}/d3xp from the RoE CD before running the game,"
+ elog "or 'emerge doom3-roe' to install from CD."
+ fi
+ fi
+
+ if ! use dedicated; then
+ echo
+ elog "To play the game, run:"
+ elog " doom3"
+ fi
+ echo
+ elog "To start the dedicated server, run:"
+ elog " doom3-ded"
+}
diff --git a/games-fps/doom3/metadata.xml b/games-fps/doom3/metadata.xml
new file mode 100644
index 000000000000..3f1bc96b891a
--- /dev/null
+++ b/games-fps/doom3/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+Science has unlocked the gates to the unknown, and now only one man stands
+between Hell and Earth. A sci-fi horror masterpiece, DOOM 3 is like nothing you
+have experienced. Dramatic storyline, pulse-pounding action, incredible
+graphics, and revolutionary technology combine to draw you into the most
+frightening and gripping first person gaming experience ever created. For more
+information, checkout http://www.doom3.com
+</longdescription>
+ <use>
+ <flag name='dedicated'>install only as a dedicated game server</flag>
+ <flag name="roe">Adds support for the Resurrection of Evil expansion</flag>
+ </use>
+</pkgmetadata>