summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 01:09:31 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:32 +0000
commit365e36d515a42a6dd5c847298641d263f75a9d50 (patch)
treedca07f9fd4c6f7d58a42db6b9510abe758839384 /games-fps/quake1-data
parentgames-fps/quake1-demodata: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-365e36d515a42a6dd5c847298641d263f75a9d50.tar.gz
gentoo-365e36d515a42a6dd5c847298641d263f75a9d50.tar.bz2
gentoo-365e36d515a42a6dd5c847298641d263f75a9d50.zip
games-fps/quake1-data: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps/quake1-data')
-rw-r--r--games-fps/quake1-data/quake1-data-2.40-r1.ebuild (renamed from games-fps/quake1-data/quake1-data-2.40.ebuild)34
1 files changed, 18 insertions, 16 deletions
diff --git a/games-fps/quake1-data/quake1-data-2.40.ebuild b/games-fps/quake1-data/quake1-data-2.40-r1.ebuild
index 6c3c9e1eb193..ed730aa32cb3 100644
--- a/games-fps/quake1-data/quake1-data-2.40.ebuild
+++ b/games-fps/quake1-data/quake1-data-2.40-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# TODO: if installing off of the 1.01 cd, need to fetch the
@@ -6,51 +6,53 @@
# http://linux.omnipotent.net/article.php?article_id=11287
# ftp://ftp.cdrom.com/pub/idgames/idstuff/quake/quake106.zip
-EAPI=5
-inherit eutils cdrom games
+EAPI=7
+
+inherit cdrom
DESCRIPTION="iD Software's Quake 1 ... the data files"
HOMEPAGE="https://www.idsoftware.com/games/quake/quake/"
-SRC_URI=""
+S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="app-arch/lha"
RDEPEND="!games-fps/quake1-demodata[symlink]"
-
-S=${WORKDIR}
+BDEPEND="app-arch/lha"
src_unpack() {
export CDROM_NAME_SET=("Existing Install" "Quake CD (1.01)" "Ultimate Quake Collection" "Quake CD (newer)")
cdrom_get_cds id1:q101_int.1:Setup/ID1:resource.1
+
if [[ ${CDROM_SET} == "1" ]] ; then
- echo ">>> Unpacking q101_int.lha to ${PWD}"
+ elog "Unpacking q101_int.lha to ${PWD}"
cat "${CDROM_ROOT}"/q101_int.1 "${CDROM_ROOT}"/q101_int.2 > \
"${S}"/q101_int.exe
+
lha xqf "${S}"/q101_int.exe || die
- rm -f q101_int.exe
+ rm -f q101_int.exe || die
elif [[ ${CDROM_SET} == "3" ]] ; then
- echo ">>> Unpacking resource.1 to ${PWD}"
+ elog "Unpacking resource.1 to ${PWD}"
lha xqf "${CDROM_ROOT}"/resource.1 || die
fi
}
src_install() {
- insinto "${GAMES_DATADIR}"/quake1/id1
+ insinto /usr/share/quake1/id1
case ${CDROM_SET} in
- 0) doins "${CDROM_ROOT}"/id1/*
+ 0)
+ doins "${CDROM_ROOT}"/id1/*
dodoc "${CDROM_ROOT}"/*.txt
;;
- 1|3)doins id1/*
+ 1|3)
+ doins id1/*
dodoc *.txt
;;
- 2) newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak
+ 2)
+ newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak
newins "${CDROM_ROOT}"/Setup/ID1/PAK1.PAK pak1.pak
dodoc "${CDROM_ROOT}"/Docs/*
;;
esac
- prepgamesdirs
}