summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/tenebrae
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/tenebrae')
-rw-r--r--games-fps/tenebrae/Manifest2
-rw-r--r--games-fps/tenebrae/files/1.04-glhax.patch32
-rw-r--r--games-fps/tenebrae/files/tenebrae-1.04-exec-stack.patch36
-rw-r--r--games-fps/tenebrae/metadata.xml15
-rw-r--r--games-fps/tenebrae/tenebrae-1.04.ebuild71
5 files changed, 156 insertions, 0 deletions
diff --git a/games-fps/tenebrae/Manifest b/games-fps/tenebrae/Manifest
new file mode 100644
index 000000000000..c479ad58b779
--- /dev/null
+++ b/games-fps/tenebrae/Manifest
@@ -0,0 +1,2 @@
+DIST tenebrae-1.04.tbz2 625988 SHA256 61277ecb41dc7c4adbfbad81cd5bfd69e3d63a8e7b41a4860bd879011a735f6c
+DIST tenebraedata.zip 3989498 SHA256 35db2e1dfe917ec5e62d8ad50fb5ccc73418a7dc3ef1e16cba9eb01f1e1177b8
diff --git a/games-fps/tenebrae/files/1.04-glhax.patch b/games-fps/tenebrae/files/1.04-glhax.patch
new file mode 100644
index 000000000000..b8615fa04a97
--- /dev/null
+++ b/games-fps/tenebrae/files/1.04-glhax.patch
@@ -0,0 +1,32 @@
+--- tenebrae_0/glquake.h.orig 2004-12-25 00:28:28.707288592 -0500
++++ tenebrae_0/glquake.h 2004-12-25 00:27:35.000000000 -0500
+@@ -34,6 +34,7 @@
+ #else
+ #include <GL/gl.h>
+ #include <GL/glu.h>
++#include <GL/glext.h>
+ #endif /* __APPLE__ ||ÊMACOSX */
+
+ /* use the correct dynamic function address binder */
+@@ -420,8 +421,10 @@
+ void GL_Bind (int texnum);
+
+ #ifndef _WIN32
++#ifndef APIENTRY
+ #define APIENTRY /* */
+ #endif
++#endif
+
+ #if !defined (__APPLE__) && !defined (MACOSX)
+
+@@ -1134,8 +1137,10 @@
+ // <AWE> There are some diffs with the function parameters. wgl stuff not present with MacOS X. -DC- and SDL
+ #if defined (__APPLE__) || defined (MACOSX) || defined(SDL) || defined (__glx__)
+
++#ifndef GL_APPLE_vertex_array_range
+ typedef void (APIENTRY * PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC) (GLsizei length, const GLvoid *pointer);
+ typedef void (APIENTRY * PFNGLVERTEXARRAYRANGEAPPLEPROC) (GLsizei size, const GLvoid *pointer);
++#endif
+
+ extern PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC qglFlushVertexArrayRangeAPPLE;
+ extern PFNGLVERTEXARRAYRANGEAPPLEPROC qglVertexArrayRangeAPPLE;
diff --git a/games-fps/tenebrae/files/tenebrae-1.04-exec-stack.patch b/games-fps/tenebrae/files/tenebrae-1.04-exec-stack.patch
new file mode 100644
index 000000000000..bc74e951fe6a
--- /dev/null
+++ b/games-fps/tenebrae/files/tenebrae-1.04-exec-stack.patch
@@ -0,0 +1,36 @@
+--- math.s
++++ math.s
+@@ -416,3 +416,6 @@
+ call C(BOPS_Error)
+
+ #endif // id386
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- snd_mixa.s
++++ snd_mixa.s
+@@ -216,3 +216,6 @@
+
+ #endif // id386
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- sys_dosa.s
++++ sys_dosa.s
+@@ -93,3 +93,6 @@
+
+ ret
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- worlda.s
++++ worlda.s
+@@ -142,3 +142,6 @@
+
+ #endif // id386
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-fps/tenebrae/metadata.xml b/games-fps/tenebrae/metadata.xml
new file mode 100644
index 000000000000..a9b54b987180
--- /dev/null
+++ b/games-fps/tenebrae/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>
+Tenebrae is a modification of the quake source that adds stencil shadows
+and per pixel lights to quake. Stencil shadows allow for realistic
+shadow effects on every object in the game world. Per pixel lighting
+allows you to have fine surface details correctly lit. These are
+essentially the same algorithms as used by the new Doom game.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tenebrae</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/tenebrae/tenebrae-1.04.ebuild b/games-fps/tenebrae/tenebrae-1.04.ebuild
new file mode 100644
index 000000000000..62476dfde213
--- /dev/null
+++ b/games-fps/tenebrae/tenebrae-1.04.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+#ECVS_SERVER="cvs.tenebrae.sourceforge.net:/cvsroot/tenebrae"
+#ECVS_MODULE="tenebrae_0"
+#inherit cvs
+inherit eutils games
+
+DESCRIPTION="adds stencil shadows and per pixel lights to quake"
+HOMEPAGE="http://tenebrae.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tenebrae/tenebraedata.zip
+ mirror://gentoo/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libpng
+ x11-libs/libXxf86vm
+ x11-libs/libXxf86dga"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ if [[ -z ${ECVS_MODULE} ]] ; then
+ unpack ${A}
+ else
+ cvs_src_unpack
+ fi
+}
+
+src_prepare() {
+ cd tenebrae_0
+
+ sed -i \
+ -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
+ gl_warp.c || die
+
+ epatch \
+ "${FILESDIR}"/${PV}-glhax.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
+ cd linux
+ sed \
+ -e "/^LDFLAGS/s:=:+=:" \
+ -e "s:-mpentiumpro -O6:${CFLAGS}:" \
+ Makefile.i386linux > Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ cd "${S}"/tenebrae_0/linux
+ emake MASTER_DIR="${GAMES_DATADIR}/quake1" build_release || die
+}
+
+src_install() {
+ newgamesbin tenebrae_0/linux/release*/bin/tenebrae.run tenebrae || die
+ insinto "${GAMES_DATADIR}/quake1/tenebrae"
+ doins "${WORKDIR}"/tenebrae/* || die "doins data"
+ dodoc tenebrae_0/linux/README "${WORKDIR}"/Tenebrae_Readme.txt
+ prepgamesdirs
+}