summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-10-26 17:21:01 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-10-26 17:25:41 +0100
commite7bef52e276faff9eee96091c2ddfaa167aa4c55 (patch)
tree39320f86d45cdefe44329276df804a4e40b5e5cd /games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
parentmedia-libs/zimg: Sync live ebuild (diff)
downloadgentoo-e7bef52e276faff9eee96091c2ddfaa167aa4c55.tar.gz
gentoo-e7bef52e276faff9eee96091c2ddfaa167aa4c55.tar.bz2
gentoo-e7bef52e276faff9eee96091c2ddfaa167aa4c55.zip
games-fps/ut2003-bonuspack-cm: Fix broken SRC_URI
The new download is a slightly different size and requires unpack_zip to work. Closes: https://bugs.gentoo.org/640552 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild')
-rw-r--r--games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
index 5e55eb9e9519..d42bd801c5ed 100644
--- a/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
+++ b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
@@ -2,12 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit games
-IUSE=""
+inherit games unpacker
+
DESCRIPTION="Community Bonus Pack for UT2003"
HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2003"
-SRC_URI="https://ut.rushbase.net/beyondunreal/mods/cbp2003.zip"
+SRC_URI="https://downloads.unrealadmin.org/UT2003/BonusPack/cbp2003.zip"
LICENSE="ut2003"
SLOT="1"
@@ -24,7 +24,7 @@ dir=${GAMES_PREFIX_OPT}/ut2003
Ddir=${D}/${dir}
src_unpack() {
- unzip -qq "${DISTDIR}"/${A} || die
+ unpack_zip "${DISTDIR}"/${A}
}
src_install() {