summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-20 23:57:19 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-10-27 23:47:59 +0000
commit7c2d1e40419001632f0c0583de144e6c4f744976 (patch)
tree7da60e85ebe67d20f332772825d5025251b9b957 /games-fps/ut2004-bonuspack-ece
parentgames-fps/ut2004-data: Fix HOMEPAGE, fix deps, drop wrapper (diff)
downloadgentoo-7c2d1e40419001632f0c0583de144e6c4f744976.tar.gz
gentoo-7c2d1e40419001632f0c0583de144e6c4f744976.tar.bz2
gentoo-7c2d1e40419001632f0c0583de144e6c4f744976.zip
games-fps/ut2004-bonuspack-ece: Port to EAPI 7
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece')
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r4.ebuild (renamed from games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild)32
1 files changed, 22 insertions, 10 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r4.ebuild
index e5ebe2ab3b90..5460ac93230a 100644
--- a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r4.ebuild
@@ -1,29 +1,34 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-MOD_DESC="Editor's Choice Edition bonus pack"
-MOD_NAME="Editor's Choice Edition"
-
-inherit games games-mods
+EAPI=7
MY_P="ut2004megapack-linux.tar.bz2"
+
+DESCRIPTION="UT2004 Editor's Choice Edition - Editor's Choice Edition bonus pack"
HOMEPAGE="http://www.unrealtournament2004.com/"
-SRC_URI="http://ut2004.ut-files.com/BonusPacks/${MY_P}
+SRC_URI="
+ http://ut2004.ut-files.com/BonusPacks/${MY_P}
http://unrealmassdestruction.com/downloads/ut2k4/essentials/UT2004-ONSBonusMapPack.zip"
LICENSE="ut2003"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
src_unpack() {
- unpack ${MY_P}
+ unpack "${MY_P}"
+
cd UT2004MegaPack/Maps || die
unpack UT2004-ONSBonusMapPack.zip # bug #278002
}
src_prepare() {
+ default
+
mv -f UT2004MegaPack/* . || die
rmdir UT2004MegaPack || die
@@ -54,3 +59,10 @@ src_prepare() {
rm System/{Core.int,Engine.int,Setup.int,Window.int} || die
rm System/{OnslaughtFull.u,OnslaughtBP.u} || die
}
+
+src_install() {
+ insinto /opt/ut2004
+ doins -r Animations Help Maps Sounds StaticMeshes System Textures
+
+ dosym ut2004 /opt/ut2004-ded
+}