summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2004-muralis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2004-muralis')
-rw-r--r--games-fps/ut2004-muralis/Manifest1
-rw-r--r--games-fps/ut2004-muralis/metadata.xml5
-rw-r--r--games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild29
3 files changed, 35 insertions, 0 deletions
diff --git a/games-fps/ut2004-muralis/Manifest b/games-fps/ut2004-muralis/Manifest
new file mode 100644
index 000000000000..10c4991ccd70
--- /dev/null
+++ b/games-fps/ut2004-muralis/Manifest
@@ -0,0 +1 @@
+DIST muralis-v1.15-zip.zip 62575050 SHA256 99d3d86585511cf0b9a37fb3b475a6685d1a4a414684def9e82befdc793fd77f
diff --git a/games-fps/ut2004-muralis/metadata.xml b/games-fps/ut2004-muralis/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/ut2004-muralis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
new file mode 100644
index 000000000000..75379f7cf030
--- /dev/null
+++ b/games-fps/ut2004-muralis/ut2004-muralis-1.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="third-person hand-to-hand single/multiplayer mod"
+MOD_NAME="Muralis"
+MOD_DIR="muralis"
+
+inherit unpacker games games-mods
+
+HOMEPAGE="http://www.ascensiongames.com/"
+SRC_URI="muralis-v${PV}-zip.zip"
+
+LICENSE="freedist"
+KEYWORDS="amd64 x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "http://www.atomicgamer.com/file.php?id=42750"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ mv -f Muralis ${MOD_DIR} || die
+}