summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-01-06 13:24:49 -0500
committerJames Le Cuirot <chewi@gentoo.org>2020-01-07 23:05:54 +0000
commit1f0e7a72bdd75897993248ccd8bf8480148b7062 (patch)
treee9954239ff2d2f2dbfd87d82876bd453eb87b6c6 /games-fps
parentdev-games/ogre: Apply BDEPEND to all unstable versions (diff)
downloadgentoo-1f0e7a72bdd75897993248ccd8bf8480148b7062.tar.gz
gentoo-1f0e7a72bdd75897993248ccd8bf8480148b7062.tar.bz2
gentoo-1f0e7a72bdd75897993248ccd8bf8480148b7062.zip
games-fps/gzdoom: Version bump to 4.3.1
The "nonfree" USE flag is renamed to "non-free". The "alsa", "fluidsynth", "mpg123", and "sndfile" USE flags are added to control support of their respective packages. Closes: https://bugs.gentoo.org/704880 Bug: https://bugs.gentoo.org/676158 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14272 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/gzdoom/Manifest2
-rw-r--r--games-fps/gzdoom/gzdoom-4.3.1.ebuild (renamed from games-fps/gzdoom/gzdoom-4.2.4.ebuild)29
-rw-r--r--games-fps/gzdoom/metadata.xml4
3 files changed, 21 insertions, 14 deletions
diff --git a/games-fps/gzdoom/Manifest b/games-fps/gzdoom/Manifest
index b1ac6d58a844..1fb177efd010 100644
--- a/games-fps/gzdoom/Manifest
+++ b/games-fps/gzdoom/Manifest
@@ -1 +1 @@
-DIST gzdoom-4.2.4.tar.gz 13683768 BLAKE2B cfdecaf6d92720b3a61fe986a63e6230674cafc65d02f5496a073ffe870319eec62c58377204fd8509fce4869b2a970cc4d1ad98db055d063393ce59d04b1d4f SHA512 555e280db3d66a643cf1412ac1bae5f8c607af339a11a61b1039061de60cf6165c41b3de0c3323ac852b0b2f63f787a1c10ba9240da3174a85ec09d61f5b271a
+DIST gzdoom-4.3.1.tar.gz 13689272 BLAKE2B 3bc26732bc2f3281d0e5a1c667226153d411048877d3a716b6e4ce89534a38cde3763e5cf5d409d99bb053e75d5922b20b4b4d93ce574de58420ae89158eab32 SHA512 6904b8a132f720f07ba15bb4959cf248bba753c318e248d882c5701d919d35492a4fb460a4d4716bc26fde8a1c59d4bceaf3f626326a90a06d4f6cde6a180b96
diff --git a/games-fps/gzdoom/gzdoom-4.2.4.ebuild b/games-fps/gzdoom/gzdoom-4.3.1.ebuild
index f6844ab0cf13..1ba984d753b4 100644
--- a/games-fps/gzdoom/gzdoom-4.2.4.ebuild
+++ b/games-fps/gzdoom/gzdoom-4.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,23 +10,24 @@ HOMEPAGE="https://zdoom.org"
SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT
- nonfree? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist )"
+ non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="gtk gtk2 +nonfree openmp"
+IUSE="alsa fluidsynth gtk gtk2 mpg123 +non-free openmp sndfile"
DEPEND="
media-libs/libsdl2[opengl]
- media-libs/libsndfile
media-libs/openal
- media-sound/fluidsynth:=
- media-sound/mpg123
sys-libs/zlib
virtual/jpeg:0
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth:= )
gtk? (
gtk2? ( x11-libs/gtk+:2 )
!gtk2? ( x11-libs/gtk+:3 )
- )"
+ )
+ mpg123? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-g${PV}"
@@ -38,7 +39,7 @@ PATCHES=(
src_prepare() {
rm -rf docs/licenses || die
- if ! use nonfree ; then
+ if ! use non-free ; then
rm -rf wadsrc_bm wadsrc_extra || die
fi
@@ -57,7 +58,11 @@ src_configure() {
-DNO_GTK="$(usex !gtk)"
-DNO_OPENAL=OFF
-DNO_OPENMP="$(usex !openmp)"
- -DBUILD_NONFREE="$(usex nonfree)"
+ -DBUILD_NONFREE="$(usex non-free)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_ALSA="$(usex !alsa)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_FluidSynth="$(usex !fluidsynth)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_MPG123="$(usex !mpg123)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_SndFile="$(usex !sndfile)"
)
cmake_src_configure
}
@@ -71,10 +76,10 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
- if ! use nonfree ; then
+ if ! use non-free ; then
ewarn
- ewarn "GZDoom installed without nonfree components."
- ewarn "Note: The nonfree game_support.pk3 file is needed to play"
+ ewarn "GZDoom installed without non-free components."
+ ewarn "Note: The non-free game_support.pk3 file is needed to play"
ewarn " games natively supported by GZDoom."
ewarn "A list of games natively supported by GZDoom is available"
ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"
diff --git a/games-fps/gzdoom/metadata.xml b/games-fps/gzdoom/metadata.xml
index 5b213dc39913..5e66764ba70e 100644
--- a/games-fps/gzdoom/metadata.xml
+++ b/games-fps/gzdoom/metadata.xml
@@ -17,8 +17,10 @@
<name>Gentoo Games Project</name>
</maintainer>
<use>
+ <flag name="fluidsynth">Enable support for MIDI via <pkg>media-sound/fluidsynth</pkg></flag>
<flag name="gtk2">Enable support for GTK+2 instead of GTK+3</flag>
- <flag name="nonfree">Enable non-free components</flag>
+ <flag name="mpg123">Enable support for MPEG audio playback via <pkg>media-sound/mpg123</pkg></flag>
+ <flag name="non-free">Enable non-free components</flag>
</use>
<upstream>
<bugs-to>https://forum.zdoom.org/viewforum.php?f=2</bugs-to>