summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2020-10-31 11:55:18 -0400
committerJames Le Cuirot <chewi@gentoo.org>2020-11-03 22:32:57 +0000
commit75a853812e3a99e93d228867b7154ae7af465f4f (patch)
treefebc0e617185cba691fb73e2f0e42fb9f4e874c3 /games-fps
parentnet-ftp/lftp: add slyfox@ to maintainers (diff)
downloadgentoo-75a853812e3a99e93d228867b7154ae7af465f4f.tar.gz
gentoo-75a853812e3a99e93d228867b7154ae7af465f4f.tar.bz2
gentoo-75a853812e3a99e93d228867b7154ae7af465f4f.zip
games-fps/gzdoom: version bump to 4.5.0
Closes: https://bugs.gentoo.org/752036 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18092 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/gzdoom/Manifest2
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.5.0-Introduce-the-BUILD_NONFREE-option.patch36
-rw-r--r--games-fps/gzdoom/gzdoom-4.5.0.ebuild82
3 files changed, 120 insertions, 0 deletions
diff --git a/games-fps/gzdoom/Manifest b/games-fps/gzdoom/Manifest
index dbfc90a7a341..094ab4d9cf1b 100644
--- a/games-fps/gzdoom/Manifest
+++ b/games-fps/gzdoom/Manifest
@@ -1,2 +1,4 @@
DIST gzdoom-4.3.3.tar.gz 13704956 BLAKE2B 4c9338b8958a408bee268eadadd779be8488540e68d5f46d7d0b18a825cd6391368b2c5149eff965685dd97f7ee51f12050e07f558c7f62551c8e239049110ea SHA512 ef8e3a7cfa4d03a98536deddb53ded4b23609b834dd07af4224cd2eb1136bca2a318a99a959a36b2e423038938a2175c015c48d89510f124bd32b7656004e1d1
DIST gzdoom-4.4.2.tar.gz 12613806 BLAKE2B 7c2f6b490abd8bd23068af7df9ebf111bb09cc7af979d7bf285e744f8cb23c69f360b8cb274ebd354f5885aabeb53c744075696ff8fd5710dd15f07f70b4395b SHA512 cf3fb4588555ef98a1c224ca07e3ab0ee00a39ad6abb4fa7e31ce7ce013f146aa2be6c8303badd7a86b21da2a689cbd1d234c46739f84ee5293745a1189226ba
+DIST gzdoom-4.5.0.tar.gz 12741814 BLAKE2B b214f36ffd1991da8d8cce3e82f0395d0ccae60755246856f5cf89aa6646ce139fc26d712e5e3f54791685318ede0ff124bd26ba900f9f5edb19b085f58dc6f5 SHA512 0b432a7cb7e99ee8d661be9d0578b9ead4087a6b4a4ffb43c5363e6eaa4e3acf682e71af98adf17663986d6dae02eea23856cbd13c42bcd92b9ffca4d727d15f
+DIST widepix-9273804.tar.gz 1327209 BLAKE2B 9ceb6470fc09600351d62c78b36652fa146f0aa7a0eadc85bcee84d72f49d2360f46d26001b8f0c22ef46abb5d15c9fb4946349cd600bf225fa9ab99be034832 SHA512 8cb6450c315efeff5b0af5a100e8be25a2add1512f236115011de427fd3ca66bf70fba015b6437c1157e97b95cd059a3bad148993677223fea5344a8e7a34060
diff --git a/games-fps/gzdoom/files/gzdoom-4.5.0-Introduce-the-BUILD_NONFREE-option.patch b/games-fps/gzdoom/files/gzdoom-4.5.0-Introduce-the-BUILD_NONFREE-option.patch
new file mode 100644
index 000000000000..64a230dcd984
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.5.0-Introduce-the-BUILD_NONFREE-option.patch
@@ -0,0 +1,36 @@
+From 9270c7bdb35d4dce2c270592011498a12a1bf6e7 Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Sat, 31 Aug 2019 21:23:23 +0900
+Subject: [PATCH] Introduce the BUILD_NONFREE option
+
+This allow users to disable building nonfree components (brightmaps.pk3,
+game_support.pk3, and game_widescreen_gfx.pk3) if they so desire.
+---
+ CMakeLists.txt | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a3763ec1f..d0c4720bd 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -400,11 +400,14 @@ add_subdirectory( libraries/lzma )
+ add_subdirectory( tools )
+ add_subdirectory( libraries/gdtoa )
+ add_subdirectory( wadsrc )
+-add_subdirectory( wadsrc_bm )
+ add_subdirectory( wadsrc_lights )
+-add_subdirectory( wadsrc_extra )
+-add_subdirectory( wadsrc_widescreen )
+ add_subdirectory( src )
++option (BUILD_NONFREE "Build nonfree components" ON)
++if( BUILD_NONFREE )
++ add_subdirectory( wadsrc_bm )
++ add_subdirectory( wadsrc_extra )
++ add_subdirectory( wadsrc_widescreen )
++endif()
+
+ if( NOT CMAKE_CROSSCOMPILING )
+ export(TARGETS ${CROSS_EXPORTS} FILE "${CMAKE_BINARY_DIR}/ImportExecutables.cmake" )
+--
+2.28.0
+
diff --git a/games-fps/gzdoom/gzdoom-4.5.0.ebuild b/games-fps/gzdoom/gzdoom-4.5.0.ebuild
new file mode 100644
index 000000000000..bf1ddc570ec4
--- /dev/null
+++ b/games-fps/gzdoom/gzdoom-4.5.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg
+
+DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
+HOMEPAGE="https://zdoom.org"
+SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz
+ non-free? ( https://github.com/nashmuhandes/WidePix/archive/92738042ca3a37f28153a09809d80a7d61090532.tar.gz -> widepix-9273804.tar.gz )"
+
+LICENSE="Apache-2.0 BSD BZIP2 GPL-3 LGPL-2.1+ LGPL-3 MIT
+ non-free? ( Activision ChexQuest3 DOOM-COLLECTORS-EDITION freedist WidePix )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gtk gtk2 +non-free openmp"
+
+DEPEND="
+ app-arch/bzip2
+ media-libs/libsdl2[opengl]
+ media-libs/openal
+ media-libs/zmusic
+ sys-libs/zlib
+ virtual/jpeg:0
+ gtk? (
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-g${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-Introduce-the-BUILD_NONFREE-option.patch"
+)
+
+src_prepare() {
+ rm -rf docs/licenses || die
+ rm -rf libraries/{bzip2,jpeg,zlib} || die
+ if ! use non-free ; then
+ rm -rf wadsrc_bm wadsrc_extra wadsrc_widescreen || die
+ else
+ mv "${WORKDIR}/WidePix-92738042ca3a37f28153a09809d80a7d61090532/filter" wadsrc_widescreen/static/ || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_DOCS_PATH="${EPREFIX}/usr/share/doc/${PF}"
+ -DINSTALL_PK3_PATH="${EPREFIX}/usr/share/doom"
+ -DINSTALL_SOUNDFONT_PATH="${EPREFIX}/usr/share/doom"
+ -DDYN_OPENAL=OFF
+ -DNO_GTK="$(usex !gtk)"
+ -DNO_OPENAL=OFF
+ -DNO_OPENMP="$(usex !openmp)"
+ -DBUILD_NONFREE="$(usex non-free)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ newicon src/posix/zdoom.xpm "${PN}.xpm"
+ make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use non-free ; then
+ ewarn
+ ewarn "GZDoom installed without non-free components."
+ ewarn "Note: The non-free game_support.pk3 file is needed to play"
+ ewarn " games natively supported by GZDoom."
+ ewarn "A list of games natively supported by GZDoom is available"
+ ewarn "on the ZDoom wiki: https://zdoom.org/wiki/IWAD"
+ ewarn
+ fi
+}