summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 19:30:20 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-17 19:39:35 -0500
commit8d3fa310a1b02a179b71c4a224a2435dd9d7132a (patch)
tree6dda5102b8a94ca37057d7c0a5bccf8dbed4495f /games-fps
parentadd slot dep for media-libs/libpng (diff)
downloadgentoo-8d3fa310a1b02a179b71c4a224a2435dd9d7132a.tar.gz
gentoo-8d3fa310a1b02a179b71c4a224a2435dd9d7132a.tar.bz2
gentoo-8d3fa310a1b02a179b71c4a224a2435dd9d7132a.zip
version bump (bug #553736)
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/darkplaces/Manifest1
-rw-r--r--games-fps/darkplaces/darkplaces-20140513.ebuild187
2 files changed, 188 insertions, 0 deletions
diff --git a/games-fps/darkplaces/Manifest b/games-fps/darkplaces/Manifest
index 1ab1250ce479..5dcaeaebc85d 100644
--- a/games-fps/darkplaces/Manifest
+++ b/games-fps/darkplaces/Manifest
@@ -1,4 +1,5 @@
DIST darkplacesengine20110628.zip 23377408 SHA256 d2464c681e3fdcc66cb090e79c44c0c173a43b6f181a12e500b0b1fd7d73ffce SHA512 bf44933470be2856a80ebd73a0cb531c6d22e69da5be24bc52175998ab687b4112c88423a6b42a9a4ed746e0f96c1bb39e188a037a98ea596cf7b6183e390038 WHIRLPOOL b4214be8a9c9aadf02a92c9b7e54d508df38f9e38f650f839a8ea43d9c0768641dbf59c71b210d337f591fac2d77a21a14e7900a3038d1af828f064bf3368071
DIST darkplacesengine20130304.zip 29427833 SHA256 e1858dcba033b1dfc6e685482745b7137ceb23dfd710671971cd5e34529a9f44 SHA512 6672160ad6ed34bb45262f03b7a7671d65aa88ca44abab616f54cd1a8e5240dcb7b8a3a7c364fc8de3e9e2acf458e5c129311a0c52b8c6b29d9a4cafa5188b15 WHIRLPOOL 5566c7de789735fb984c5b64cf7ece2e948b87e170e16f434d5015f70baad901aadc251bb25a32926f43ced903daaa914a51024c08a64f4edcf1a9003aab1261
+DIST darkplacesengine20140513.zip 28113487 SHA256 69e5a50991884196e403bd6aab4a33bba553a934a167be366672ab4e223b06c9 SHA512 45864b590057c6de0ea978b3cc967feb879b87b2d376f3b4d8525e037b10ca1fc68599c152506494bb06669c6c2304e0aa0ee1b28f7a0d589d10c23f7285052c WHIRLPOOL 0fca6d87c9d3482112992965b70f829dfd6ecd926d940ad66f5f75aec4438c2b5b33fb6ac51f69c5199f06d53fbc16f1c8d0780db40b8cbd71c7ceb0e67a4048
DIST fuhquake-lits.rar 8388829 SHA256 066fd58e2a6d157a1aa7925334d7e3e6cffa7f5c556e707bc31da8bfecea873c SHA512 6e59f5e08a6c401b329b86b0cd677a04b1a5aee11f24973c77c9e7ea50cab9dedf4fc15c4f3d6b73bdc87bacdc9612a3c244d0a4ceceef943abb6e256ac23925 WHIRLPOOL d398b57c03d02c8180f8ca93f6964ac2118ef50cace3ecbc9da9113b1e91ed3a7b7e5473ebb9ad2f5198828eb8565c7c0470aea2095152b2898335562bef821d
DIST id1.pk3 350470 SHA256 f1ee6e144d1942ebf91a8c71d0333eac94c73efae35377fbe7ae43e0e4ab37dc SHA512 d4d7233bc1e5049e89d09448818219b0ce7941fecde5381cd95933e4c96ebc9b4e34ff7eae5eb5d0d1e3cc2ceb4f5254f4d600aded7dda373713149817621331 WHIRLPOOL 30fe7e6d6ac6408c54e704586d4f4e15d139c0330e4f3e758651bfc2e6582eadae08c590e87264cfb26faae56a7033b383d51f93bf54ddfce7db38e47d569280
diff --git a/games-fps/darkplaces/darkplaces-20140513.ebuild b/games-fps/darkplaces/darkplaces-20140513.ebuild
new file mode 100644
index 000000000000..a8791590a227
--- /dev/null
+++ b/games-fps/darkplaces/darkplaces-20140513.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit unpacker eutils flag-o-matic games
+
+# Latest versions are in http://icculus.org/twilight/darkplaces/files/
+MY_PV=${PV/_beta/beta}
+MY_ENGINE="${PN}engine${MY_PV}.zip"
+
+# Different Quake 1 engines expect the lights in different directories
+# http://www.fuhquake.net/download.html and http://www.kgbsyndicate.com/romi/
+MY_LIGHTS="fuhquake-lits.rar"
+
+DESCRIPTION="Enhanced engine for iD Software's Quake 1"
+HOMEPAGE="http://icculus.org/twilight/darkplaces/"
+SRC_URI="http://icculus.org/twilight/${PN}/files/${MY_ENGINE}
+ lights? (
+ http://www.fuhquake.net/files/extras/${MY_LIGHTS}
+ http://www.kgbsyndicate.com/romi/id1.pk3 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cdinstall cdsound debug dedicated demo lights opengl oss sdl textures"
+
+UIRDEPEND="virtual/jpeg:0
+ media-libs/libogg
+ media-libs/libvorbis
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ sdl? ( media-libs/libsdl )
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm"
+UIDEPEND="x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="net-misc/curl
+ cdinstall? ( games-fps/quake1-data )
+ demo? ( games-fps/quake1-demodata )
+ textures? ( >=games-fps/quake1-textures-20050820 )
+ opengl? ( ${UIRDEPEND} )
+ !opengl? ( sdl? ( ${UIRDEPEND} ) )
+ !opengl? ( !sdl? ( !dedicated? ( ${UIRDEPEND} ) ) )"
+DEPEND="lights? ( || (
+ app-arch/unrar
+ app-arch/rar ) )
+ opengl? (
+ ${UIRDEPEND}
+ ${UIDEPEND} )
+ !opengl? ( sdl? (
+ ${UIRDEPEND}
+ ${UIDEPEND} ) )
+ !opengl? ( !sdl? ( !dedicated? (
+ ${UIRDEPEND}
+ ${UIDEPEND} ) ) )
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+dir=${GAMES_DATADIR}/quake1
+
+opengl_client() { use opengl || ( ! use dedicated && ! use sdl ) }
+
+src_unpack() {
+ if use lights ; then
+ unpack "${MY_LIGHTS}"
+ unpack_zip "${DISTDIR}"/id1.pk3
+ mv *.lit maps/ || die
+ mv ReadMe.txt rtlights.txt
+ fi
+ unpack "${MY_ENGINE}"
+ unpack ./${PN}*.zip
+}
+
+src_prepare() {
+ rm "${WORKDIR}"/README-SDL.txt
+ cd "${S}"
+ rm mingw_note.txt
+
+ strip-flags
+
+ # Only additional CFLAGS optimization is the -march flag
+ local march=$(get-flag -march)
+ sed -i \
+ -e "s:-lasound:$(pkg-config --libs alsa):" \
+ -e "/^CPUOPTIMIZATIONS/d" \
+ -e '/^OPTIM_RELEASE/s/=.*/=$(CFLAGS)/' \
+ -e '/^OPTIM_DEBUG/s/=.*/=$(CFLAGS)/' \
+ -e '/^LDFLAGS_DEBUG/s/$/ $(LDFLAGS)/' \
+ -e '/^LDFLAGS_RELEASE/s/$/ $(LDFLAGS)/' \
+ -e "s:strip:true:" \
+ makefile.inc || die
+
+ if ! use cdsound ; then
+ # Turn the CD accesses off
+ sed -i \
+ -e "s:/dev/cdrom:/dev/null:" \
+ cd_linux.c || die
+ sed -i \
+ -e 's:COM_CheckParm("-nocdaudio"):1:' \
+ cd_shared.c || die
+ fi
+}
+
+src_compile() {
+ local opts="DP_FS_BASEDIR=\"${dir}\" DP_LINK_TO_LIBJPEG=1"
+
+ # Preferred sound is alsa
+ local sound_api="NULL"
+ use oss && sound_api="OSS"
+ use alsa && sound_api="ALSA"
+ opts="${opts} DP_SOUND_API=${sound_api}"
+
+ local type="release"
+ use debug && type="debug"
+
+ # Only compile a maximum of 1 client
+ if use sdl ; then
+ emake ${opts} "sdl-${type}"
+ elif opengl_client ; then
+ emake ${opts} "cl-${type}"
+ fi
+
+ if use dedicated ; then
+ emake ${opts} "sv-${type}"
+ fi
+}
+
+src_install() {
+ if opengl_client || use sdl ; then
+ local type=glx
+
+ use sdl && type=sdl
+
+ # darkplaces executable is needed, even just for demo
+ newgamesbin "${PN}-${type}" ${PN}
+ newicon darkplaces72x72.png ${PN}.png
+
+ if use demo ; then
+ # Install command-line for demo, even if not desktop entry
+ games_make_wrapper ${PN}-demo "${PN} -game demo"
+ fi
+
+ if use demo && ! use cdinstall ; then
+ make_desktop_entry ${PN}-demo "Dark Places (Demo)"
+ else
+ # Full version takes precedence over demo
+ make_desktop_entry ${PN} "Dark Places"
+ fi
+ fi
+
+ if use dedicated ; then
+ newgamesbin ${PN}-dedicated ${PN}-ded
+ fi
+
+ dodoc *.txt ChangeLog todo "${WORKDIR}"/*.txt
+
+ if use lights ; then
+ insinto "${dir}"/id1
+ doins -r "${WORKDIR}"/{cubemaps,maps}
+ if use demo ; then
+ # Set up symlinks, for the demo levels to include the lights
+ local d
+ for d in cubemaps maps ; do
+ dosym "${dir}/id1/${d}" "${dir}/demo/${d}"
+ done
+ fi
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall && ! use demo ; then
+ elog "Place pak0.pak and pak1.pak in ${dir}/id1"
+ fi
+
+ if use sdl ; then
+ ewarn "Select opengl with alsa, instead of sdl USE flag, for better audio latency."
+ fi
+}