summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-01-27 19:29:20 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-01 18:45:40 +0100
commitba7dd574540c3edb0bb129fabe1be7dd38859e84 (patch)
treeb75c18915219ddb90361529e522d5a7fdd448f75 /games-fps
parentdev-libs/boost: remove unused patches (diff)
downloadgentoo-ba7dd574540c3edb0bb129fabe1be7dd38859e84.tar.gz
gentoo-ba7dd574540c3edb0bb129fabe1be7dd38859e84.tar.bz2
gentoo-ba7dd574540c3edb0bb129fabe1be7dd38859e84.zip
games-fps/redeclipse: revision bump, fix installation
This revision fixes the incorrect installation of the desktop file entry, and provides a wrapper script to address the runtime problem introduced by no longer using EAPI 5's games installation paths. Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6979
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/redeclipse/files/redeclipse10
-rw-r--r--games-fps/redeclipse/redeclipse-1.6.0-r1.ebuild (renamed from games-fps/redeclipse/redeclipse-1.6.0.ebuild)6
2 files changed, 15 insertions, 1 deletions
diff --git a/games-fps/redeclipse/files/redeclipse b/games-fps/redeclipse/files/redeclipse
new file mode 100644
index 000000000000..667765d11d93
--- /dev/null
+++ b/games-fps/redeclipse/files/redeclipse
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# It is necessary to run the binary from the root of the data directory
+# for the binary to properly locate its assets and load properly.
+# Upstream's original install procedure is doing the same thing.
+
+SERVER=/usr/bin/redeclipse_server_linux
+CLIENT=/usr/bin/redeclipse_linux
+cd /usr/share/redeclipse || exit 1
+[ "$0" = "redeclipse_server" ] && exec $SERVER || exec $CLIENT
diff --git a/games-fps/redeclipse/redeclipse-1.6.0.ebuild b/games-fps/redeclipse/redeclipse-1.6.0-r1.ebuild
index 173ab9a6b751..5a45262fd901 100644
--- a/games-fps/redeclipse/redeclipse-1.6.0.ebuild
+++ b/games-fps/redeclipse/redeclipse-1.6.0-r1.ebuild
@@ -70,10 +70,14 @@ src_install() {
if ! use dedicated; then
dobin src/redeclipse_linux
newicon "src/install/nix/${PN}_x128.png" "${PN}.png"
- make_desktop_entry "src/install/nix/${PN}.desktop"
+ domenu "src/install/nix/${PN}.desktop"
doman doc/man/redeclipse.6
fi
+ dobin "${FILESDIR}/redeclipse"
+ cd /usr/bin || die
+ dosym redeclipse redeclipse_server
+
doman doc/man/redeclipse-server.6
dodoc readme.txt doc/examples/servinit.cfg
}