summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-09-01 12:24:31 +0900
committerJames Le Cuirot <chewi@gentoo.org>2019-09-05 21:08:54 +0100
commitbbe77ee0db93eab854216714c09f8f7e23960bce (patch)
tree5d7225a40c63b2a3a4138dfd49974ff43c95265d /games-fps
parentgames-fps/freedoom-data: Drop old (diff)
downloadgentoo-bbe77ee0db93eab854216714c09f8f7e23960bce.tar.gz
gentoo-bbe77ee0db93eab854216714c09f8f7e23960bce.tar.bz2
gentoo-bbe77ee0db93eab854216714c09f8f7e23960bce.zip
games-fps/freedm-data: Build from source
Closes: https://bugs.gentoo.org/689306 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/freedm-data/Manifest1
-rw-r--r--games-fps/freedm-data/files/ImageMagick/policy.xml4
-rw-r--r--games-fps/freedm-data/freedm-data-0.11.3-r1.ebuild57
3 files changed, 62 insertions, 0 deletions
diff --git a/games-fps/freedm-data/Manifest b/games-fps/freedm-data/Manifest
index 3c4282d51970..9cafdbdf10ac 100644
--- a/games-fps/freedm-data/Manifest
+++ b/games-fps/freedm-data/Manifest
@@ -1 +1,2 @@
DIST freedm-0.11.3.zip 7853186 BLAKE2B 5f399233e0d1f1c61d8170dc8e13ca0c6efe79255a87511027ad69e9ab7cf21045e9bc7f40fec6fa3604b3c77590cde8e85b2e9a53e1d89c5aeaf67bffa7023e SHA512 263f126e519a883b828b4f321363fe0f8c557ae58b76c6b3e28aa60e86c15fcc78c866bf003fc523276cefbb431023de64f09b026e85b0a0c7c85a88d1f47cd0
+DIST freedoom-0.11.3.tar.gz 17010131 BLAKE2B a0b601575da8516cf9f83466fe2146b708aa3cb21a3df2f7cbcd018a560f65b9b89c85907115050c4985b64eff29a3a9d2cfb7d31e93043e9d3c35fe7749d749 SHA512 51e0d5f7ca7c846c556fcba36b0f9c815090bfc76a80200aebd1526291da16b71145fbe254100cc5ad37ffc044d4380ef07b8bd4bdb811f00b9150e7b34dd636
diff --git a/games-fps/freedm-data/files/ImageMagick/policy.xml b/games-fps/freedm-data/files/ImageMagick/policy.xml
new file mode 100644
index 000000000000..ffacb9209fb3
--- /dev/null
+++ b/games-fps/freedm-data/files/ImageMagick/policy.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<policymap>
+ <policy domain="coder" rights="read | write" pattern="PS" />
+</policymap>
diff --git a/games-fps/freedm-data/freedm-data-0.11.3-r1.ebuild b/games-fps/freedm-data/freedm-data-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..99ce657c7869
--- /dev/null
+++ b/games-fps/freedm-data/freedm-data-0.11.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit python-any-r1 xdg
+
+DESCRIPTION="Game resources for FreeDM"
+HOMEPAGE="https://freedoom.github.io"
+SRC_URI="https://github.com/freedoom/freedoom/archive/v${PV}.tar.gz -> freedoom-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/pillow[${PYTHON_USEDEP}]')
+ app-text/asciidoc
+ games-util/deutex
+ virtual/imagemagick-tools[png]"
+
+S="${WORKDIR}/freedoom-${PV}"
+
+DOOMWADPATH=share/doom
+
+python_check_deps() {
+ has_version -b "dev-python/pillow[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ # This is to enable usage of the 'PS' coder, which is
+ # disabled by default (https://bugs.gentoo.org/664236)
+ install -D -t ~/.config/ImageMagick "${FILESDIR}"/ImageMagick/policy.xml || die
+
+ xdg_src_prepare
+ eapply_user
+}
+
+src_compile() {
+ emake wads/freedm.wad
+}
+
+src_install() {
+ emake install-freedm \
+ prefix="${ED}/usr/" \
+ bindir="bin/" \
+ mandir="share/man/" \
+ waddir="${DOOMWADPATH}/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "FreeDM WAD file installed into ${EPREFIX}/usr/${DOOMWADPATH} directory."
+}