summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/pytraffic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/pytraffic')
-rw-r--r--games-kids/pytraffic/Manifest1
-rw-r--r--games-kids/pytraffic/files/pytraffic6
-rw-r--r--games-kids/pytraffic/metadata.xml8
-rw-r--r--games-kids/pytraffic/pytraffic-2.5.4-r1.ebuild87
4 files changed, 102 insertions, 0 deletions
diff --git a/games-kids/pytraffic/Manifest b/games-kids/pytraffic/Manifest
new file mode 100644
index 000000000000..74793c140352
--- /dev/null
+++ b/games-kids/pytraffic/Manifest
@@ -0,0 +1 @@
+DIST pytraffic-2.5.4.tar.gz 2474006 SHA256 7a3254f5a37d71104a1223d960ce8b5d23d40caa4b2b8b8b6236d6a762c00a2a SHA512 c34a9b783e7de998b8ebc39c2ed2bf1b9a40b090c498773297da455b182aaa5f2047fb541bb11a91e11abdeffee9f02b04a37861135c5fa946fccabfc21b44c1 WHIRLPOOL 0e5c76c3d6b409bb93f9f83218a1fa1705d5f6d38041b161846a5137a1b63497a09891f80d543a058a2fc4748ae3802e9dc8074adf24bba2ac3902abdeb2ec18
diff --git a/games-kids/pytraffic/files/pytraffic b/games-kids/pytraffic/files/pytraffic
new file mode 100644
index 000000000000..30ab25196ce7
--- /dev/null
+++ b/games-kids/pytraffic/files/pytraffic
@@ -0,0 +1,6 @@
+#!/usr/bin/env python
+
+import os
+os.chdir("@GAMES_DATADIR@")
+import pytraffic.Main
+
diff --git a/games-kids/pytraffic/metadata.xml b/games-kids/pytraffic/metadata.xml
new file mode 100644
index 000000000000..e337a6e70f15
--- /dev/null
+++ b/games-kids/pytraffic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="freecode">pytraffic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-kids/pytraffic/pytraffic-2.5.4-r1.ebuild b/games-kids/pytraffic/pytraffic-2.5.4-r1.ebuild
new file mode 100644
index 000000000000..f1ccf1eac8fd
--- /dev/null
+++ b/games-kids/pytraffic/pytraffic-2.5.4-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils python-utils-r1 python-r1 distutils-r1 games
+
+DESCRIPTION="Python version of the board game Rush Hour"
+HOMEPAGE="http://freecode.com/projects/pytraffic"
+SRC_URI="http://alpha.uhasselt.be/Research/Algebra/Members/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0[sound]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}
+ dev-python/pygtk"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # FHS compliance
+ sed -i \
+ -e 's#return os.path.join(exec_dir,path)#return os.path.join(os.getcwd(),path)#' \
+ Misc.py || die
+
+ sed \
+ -e "s#@GAMES_DATADIR@#${GAMES_DATADIR}/${PN}#" \
+ "${FILESDIR}"/${PN} > "${T}"/${PN} || die
+}
+
+python_install() {
+ # install modules manually, build system broken
+ python_moduleinto ${PN}
+ python_domodule "${BUILD_DIR}"/lib/.
+
+ # allow to import the stuff as module
+ touch "${D}$(python_get_sitedir)"/${PN}/__init__.py || die
+
+ # install python wrapper script to handle multiple ABI properly
+ python_scriptinto "${GAMES_BINDIR}"
+ python_doscript "${T}"/${PN}
+}
+
+python_install_all() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r doc config.db extra_themes icons libglade music sound_test themes ttraffic.levels
+
+ doicon -s 64 icons/64x64/${PN}.png
+ make_desktop_entry ${PN} PyTraffic
+
+ dodoc AUTHORS CHANGELOG README
+
+ prepgamesdirs
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}