summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-11 15:58:49 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-11 17:55:47 -0500
commit2e52ea0a81f1f4d310200fb34a715d5143c0655d (patch)
tree7e7bd193d4a9bd87dc6e37a74a9fa2f497d3bf13 /games-misc/bsod
parentgames-strategy/triplea: Libs (#596468), drop games eclass, fix paths (diff)
downloadgentoo-2e52ea0a81f1f4d310200fb34a715d5143c0655d.tar.gz
gentoo-2e52ea0a81f1f4d310200fb34a715d5143c0655d.tar.bz2
gentoo-2e52ea0a81f1f4d310200fb34a715d5143c0655d.zip
games-misc/bsod: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-misc/bsod')
-rw-r--r--games-misc/bsod/bsod-0.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-misc/bsod/bsod-0.1-r1.ebuild b/games-misc/bsod/bsod-0.1-r1.ebuild
new file mode 100644
index 000000000000..4d4472b2ed1d
--- /dev/null
+++ b/games-misc/bsod/bsod-0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="This program will let your UNIX user experience the authentic Microsoft Windows experience"
+HOMEPAGE="http://www.vanheusden.com/bsod/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Makefile.patch
+)
+
+src_prepare() {
+ default
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Changes
+}