summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 10:10:16 +0000
committerSam James <sam@gentoo.org>2021-04-04 10:11:03 +0000
commit697bb0de8704a4ab3d92638a5dd4383cc73aa4f5 (patch)
treeb7edb29cea2de7e5d562630cfadac7aebbe83d21 /games-misc/papers-please
parentgames-misc/lucidlife: port to EAPI 7, eutils-- (diff)
downloadgentoo-697bb0de8704a4ab3d92638a5dd4383cc73aa4f5.tar.gz
gentoo-697bb0de8704a4ab3d92638a5dd4383cc73aa4f5.tar.bz2
gentoo-697bb0de8704a4ab3d92638a5dd4383cc73aa4f5.zip
games-misc/papers-please: port to EAPI 7, games.eclass--, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-misc/papers-please')
-rw-r--r--games-misc/papers-please/papers-please-1.1.65.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/games-misc/papers-please/papers-please-1.1.65.ebuild b/games-misc/papers-please/papers-please-1.1.65.ebuild
index db15ecb72c8b..59cdcab89c93 100644
--- a/games-misc/papers-please/papers-please-1.1.65.ebuild
+++ b/games-misc/papers-please/papers-please-1.1.65.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils games
+inherit desktop wrapper
DESCRIPTION="A Dystopian Document Thriller"
HOMEPAGE="http://papersplea.se"
SRC_URI="papers-please_${PV}_i386.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="PAPERS-PLEASE"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RESTRICT="fetch bindist"
-QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/*"
+QA_PREBUILT="opt/${PN}/*"
RDEPEND="
amd64? (
@@ -39,8 +39,6 @@ RDEPEND="
virtual/opengl
)"
-S=${WORKDIR}/${PN}
-
pkg_nofetch() {
einfo
einfo "Please buy & download ${SRC_URI} from:"
@@ -55,16 +53,14 @@ src_prepare() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=/opt/${PN}
- insinto "${dir}"
+ insinto ${dir}
doins -r *
- fperms +x "${dir}"/PapersPlease
+ fperms +x ${dir}/PapersPlease
- games_make_wrapper ${PN} "./PapersPlease" "${dir}" "${dir}"
+ make_wrapper ${PN} "./PapersPlease" "${dir}" "${dir}"
make_desktop_entry ${PN} "Papers, Please"
dodoc "${T}"/README
-
- prepgamesdirs
}