summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-12-18 12:52:45 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-12-18 13:00:27 +0000
commit803ddbcb6f67c28f676148293b9bf9037020ddda (patch)
treeb32bedf75280293b6cf6921e2489a5125cfe9095 /games-misc/ponysay/ponysay-3.0.2.ebuild
parentsci-geosciences/qgis: Version bump 2.18.2 (diff)
downloadgentoo-803ddbcb6f67c28f676148293b9bf9037020ddda.tar.gz
gentoo-803ddbcb6f67c28f676148293b9bf9037020ddda.tar.bz2
gentoo-803ddbcb6f67c28f676148293b9bf9037020ddda.zip
games-misc/ponysay: New package to supersede one from aidstu-overlay
zsh-completion is broken in the latest release but I have included it anyway. Package-Manager: portage-2.3.3
Diffstat (limited to 'games-misc/ponysay/ponysay-3.0.2.ebuild')
-rw-r--r--games-misc/ponysay/ponysay-3.0.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-misc/ponysay/ponysay-3.0.2.ebuild b/games-misc/ponysay/ponysay-3.0.2.ebuild
new file mode 100644
index 000000000000..961769000636
--- /dev/null
+++ b/games-misc/ponysay/ponysay-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="cowsay reimplemention for ponies"
+HOMEPAGE="https://github.com/erkin/ponysay"
+SRC_URI="https://github.com/erkin/ponysay/archive/3.0.2.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +non-free bash-completion fish-completion zsh-completion"
+
+DEPEND="${PYTHON_DEPS}
+ doc? ( sys-apps/texinfo )"
+
+RDEPEND="${PYTHON_DEPS}
+ fish-completion? ( app-shells/fish )
+ zsh-completion? ( app-shells/zsh )"
+
+setup_py() {
+ "${PYTHON}" setup.py \
+ --prefix="${EPREFIX}"/usr \
+ --everything \
+ --without-info-compression \
+ --without-man-compression \
+ --without-pdf-compression \
+ --without-shared-cache \
+ --freedom=$(usex non-free no yes) \
+ $(use_with fish-completion) \
+ $(use_with zsh-completion) \
+ $(use_with doc info) \
+ $(use_with doc pdf "${EPREFIX}"/usr/share/doc/${PF}) \
+ "${@}" || die
+}
+
+src_compile() {
+ setup_py \
+ $(use_with bash-completion) \
+ build
+}
+
+src_install() {
+ setup_py \
+ --without-bash-completion \
+ --destdir="${D}" \
+ prebuilt
+
+ python_fix_shebang "${ED}"/usr/bin/${PN}
+
+ rm -rv "${ED}"/usr/share/licenses || die
+ dodoc CHANGELOG CONTRIBUTING CREDITS README.md
+
+ use bash-completion &&
+ newbashcomp completion/bash-completion.${PN}.install ${PN}
+}