summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-08 05:23:34 +0000
committerSam James <sam@gentoo.org>2020-08-08 05:23:34 +0000
commit0319ec3082b4e56206396684dd02eb9c71eda223 (patch)
treeaac03872fc32fcecccab15558e63feb975c8d6e7 /games-misc
parentmedia-libs/libjpeg-turbo: fix tests on ppc (diff)
downloadgentoo-0319ec3082b4e56206396684dd02eb9c71eda223.tar.gz
gentoo-0319ec3082b4e56206396684dd02eb9c71eda223.tar.bz2
gentoo-0319ec3082b4e56206396684dd02eb9c71eda223.zip
games-misc/lolcat: install lolcat binary
Closes: https://bugs.gentoo.org/721718 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/lolcat/lolcat-100.0.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-misc/lolcat/lolcat-100.0.1-r1.ebuild b/games-misc/lolcat/lolcat-100.0.1-r1.ebuild
new file mode 100644
index 000000000000..6e6c7c7a0854
--- /dev/null
+++ b/games-misc/lolcat/lolcat-100.0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="lolcat.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rainbows and unicorns!"
+HOMEPAGE="https://github.com/busyloop/lolcat"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/optimist:3
+ >=dev-ruby/paint-2.1:0"
+
+all_ruby_prepare() {
+ sed -e '/manpages/ s:^:#:' \
+ -e 's/git ls-files --/echo/' \
+ -e 's/git ls-files/find/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ doman man/lolcat.6
+ ruby_fakegem_binwrapper lolcat
+}