summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 02:05:35 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:49 +0100
commit872469e2855295b758cb0bf7951f0d0e592d4344 (patch)
treea9daf2a2323abcab421496154fca514a9c56e075 /games-misc
parentgames-puzzle/tiny-and-big: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-872469e2855295b758cb0bf7951f0d0e592d4344.tar.gz
gentoo-872469e2855295b758cb0bf7951f0d0e592d4344.tar.bz2
gentoo-872469e2855295b758cb0bf7951f0d0e592d4344.zip
games-misc/little-inferno: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/little-inferno/little-inferno-20130509-r1.ebuild (renamed from games-misc/little-inferno/little-inferno-20130509.ebuild)28
1 files changed, 14 insertions, 14 deletions
diff --git a/games-misc/little-inferno/little-inferno-20130509.ebuild b/games-misc/little-inferno/little-inferno-20130509-r1.ebuild
index 8461d5670943..e85ac2cbf70f 100644
--- a/games-misc/little-inferno/little-inferno-20130509.ebuild
+++ b/games-misc/little-inferno/little-inferno-20130509-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils gnome2-utils unpacker games
+EAPI=7
+
+inherit desktop gnome2-utils unpacker wrapper
DESCRIPTION="Throw your toys into your fire, and play with them as they burn"
HOMEPAGE="http://tomorrowcorporation.com/"
@@ -12,9 +13,10 @@ LICENSE="Gameplay-Group-EULA"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="bundled-libs"
+
RESTRICT="bindist fetch bundled-libs? ( splitdebug )"
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+MYGAMEDIR=opt/${PN}
QA_PREBUILT="${MYGAMEDIR#/}/LittleInferno.bin.x86
${MYGAMEDIR#/}/lib/*"
@@ -25,8 +27,10 @@ RDEPEND="
!bundled-libs? (
>=media-libs/libogg-1.3.1[abi_x86_32(-)]
>=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
- >=media-libs/openal-1.15.1-r1[abi_x86_32(-)] )"
-DEPEND="app-arch/xz-utils"
+ >=media-libs/openal-1.15.1-r1[abi_x86_32(-)]
+ )
+"
+BDEPEND="app-arch/xz-utils"
src_unpack() {
unpack_makeself ${A}
@@ -42,31 +46,27 @@ src_unpack() {
}
src_prepare() {
- if use !bundled-libs ; then
+ if ! use bundled-libs ; then
rm -rv lib || die
fi
}
src_install() {
- insinto "${MYGAMEDIR}"
+ insinto ${MYGAMEDIR}
doins -r *
doicon -s 128 LittleInferno.png
make_desktop_entry ${PN} "Little Inferno" LittleInferno
- games_make_wrapper ${PN} "./LittleInferno.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
-
- fperms +x "${MYGAMEDIR}"/LittleInferno.bin.x86
+ make_wrapper ${PN} "./LittleInferno.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
- prepgamesdirs
+ fperms +x ${MYGAMEDIR}/LittleInferno.bin.x86
}
pkg_preinst() {
- games_pkg_preinst
gnome2_icon_savelist
}
pkg_postinst() {
- games_pkg_postinst
gnome2_icon_cache_update
}