summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-05-21 00:31:58 +0300
committerJames Le Cuirot <chewi@gentoo.org>2021-06-28 23:12:57 +0100
commitfa740e0b901f8681e40d5f8426bd383e1c116a44 (patch)
treef35777b4552d1b37d0bb709f9a38f379141fccde /games-misc
parentgames-misc/openmsx: update to 0.4.0 (diff)
downloadgentoo-fa740e0b901f8681e40d5f8426bd383e1c116a44.tar.gz
gentoo-fa740e0b901f8681e40d5f8426bd383e1c116a44.tar.bz2
gentoo-fa740e0b901f8681e40d5f8426bd383e1c116a44.zip
games-misc/openmsx: remove old version
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/openmsx/Manifest1
-rw-r--r--games-misc/openmsx/files/openmsx-0.3.1-python3.patch306
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r5.ebuild35
3 files changed, 0 insertions, 342 deletions
diff --git a/games-misc/openmsx/Manifest b/games-misc/openmsx/Manifest
index 249ae178c071..26ae53393b91 100644
--- a/games-misc/openmsx/Manifest
+++ b/games-misc/openmsx/Manifest
@@ -1,2 +1 @@
-DIST openmsx-0.3.1-source.tar.gz 152798 BLAKE2B 8c6d757b708bf5af9312318d13bf99b7326ed3cf82d158c4e639e04eab5c722d76976820a6a8913cef93246225578fcbd598afde11f09cdadc47d626d977d947 SHA512 e455f99f32d1daa77157def4f109dd1456169ae2b527290035b6a52f591c13fb7464fd221e00eb46bf03f51e8d0101de08a9e47cebe2430ad05a840ab235973e
DIST openmsx-0.4.0-source.tar.xz 114608 BLAKE2B e693b206cf350ee46b1fc5b7bf4d2a666ae7bee0fea1e2df3a29cfcfd3dbddd58d7d20d8184d6d367d377869ee5e2f970a8721cc1a1ec39babf1352a600bc759 SHA512 9a34a2f7fd9529d8b2d03f47c307a6818ecd753e8f8205c18c966d7425bf8d4a4409cd365b9d1a04d4b00d994da9e73d4270e29af3a388f48f07d3d83486e225
diff --git a/games-misc/openmsx/files/openmsx-0.3.1-python3.patch b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
deleted file mode 100644
index df403e27a22a..000000000000
--- a/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
+++ /dev/null
@@ -1,306 +0,0 @@
-From 5857a22e79dc77c9b571297451dc11c4a68bc198 Mon Sep 17 00:00:00 2001
-From: Stefan Strogin <steils@gentoo.org>
-Date: Fri, 7 Feb 2020 13:15:16 +0200
-Subject: [PATCH] Fix: support Python 3
-
-Correct tabs and spaces in scripts to make them consistent.
-Don't call deprecated methods.
-
-Upstream-Status: Submitted [https://github.com/OpenTTD/OpenMSX/pull/2]
-Signed-off-by: Stefan Strogin <steils@gentoo.org>
----
- scripts/authorlist.py | 20 ++++++++---------
- scripts/md5list.py | 48 ++++++++++++++++++++--------------------
- scripts/midifiles.py | 30 ++++++++++++-------------
- scripts/namelist.py | 34 ++++++++++++++--------------
- scripts/playlist.py | 42 +++++++++++++++++------------------
- scripts/sanitize_list.py | 48 ++++++++++++++++++++--------------------
- 6 files changed, 111 insertions(+), 111 deletions(-)
-
-diff --git a/scripts/authorlist.py b/scripts/authorlist.py
-index 689ddb9..e041d64 100755
---- a/scripts/authorlist.py
-+++ b/scripts/authorlist.py
-@@ -14,14 +14,14 @@ import string
- import sys
-
- while 1:
-- data = sys.stdin.readline()
-- if data != '':
-- # do some processing of the contents of
-- # the data variable
-- separate = string.split(data,";")
-- print '%-30s %s' % (separate[1]+":", separate[2])
-- # end of data processing command group
-+ data = sys.stdin.readline()
-+ if data != '':
-+ # do some processing of the contents of
-+ # the data variable
-+ separate = data.split(';')
-+ print('%-30s %s' % (separate[1]+":", separate[2]))
-+ # end of data processing command group
- # sys.stdout.write(res)
-- else:
-- sys.stdout.flush()
-- break
-+ else:
-+ sys.stdout.flush()
-+ break
-diff --git a/scripts/md5list.py b/scripts/md5list.py
-index cf611fc..781052e 100755
---- a/scripts/md5list.py
-+++ b/scripts/md5list.py
-@@ -16,28 +16,28 @@ import subprocess
- import os
-
- while 1:
-- data = sys.stdin.readline()
-- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- systemtype = (os.uname())[0]
-- if systemtype == 'Linux':
-- md5call = ["md5sum"]
-- elif systemtype == 'Darwin':
-- md5call = ["md5", "-r"]
-+ data = sys.stdin.readline()
-+ if data != '':
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(';')
-+ if len(separate) != 4:
-+ continue
-+ systemtype = (os.uname())[0]
-+ if systemtype == 'Linux':
-+ md5call = ["md5sum"]
-+ elif systemtype == 'Darwin':
-+ md5call = ["md5", "-r"]
-+ else:
-+ md5call = ["md5sum"]
-+ md5call = md5call + ["src/"+separate[1].strip()]
-+ md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
-+ md5sum = md5sum.split()
-+ res = "%-32s = %s\n" % (separate[1], md5sum[0].decode())
-+ sys.stdout.write(res)
- else:
-- md5call = ["md5sum"]
-- md5call = md5call + ["src/"+string.strip(separate[1])]
-- md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
-- md5sum = string.split(md5sum)
-- res = "%-32s = %s\n" % (separate[1], md5sum[0])
-- sys.stdout.write(res)
-- else:
-- sys.stdout.flush()
-- break
-+ sys.stdout.flush()
-+ break
-diff --git a/scripts/midifiles.py b/scripts/midifiles.py
-index 3b5ec57..a89e4f2 100755
---- a/scripts/midifiles.py
-+++ b/scripts/midifiles.py
-@@ -15,18 +15,18 @@ import sys
-
- res = ""
- while 1:
-- data = sys.stdin.readline()
-- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- res = res + " src/" + string.strip(separate[1])
-- else:
-- sys.stdout.write(res)
-- sys.stdout.flush()
-- break
-+ data = sys.stdin.readline()
-+ if data != '':
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(';')
-+ if len(separate) != 4:
-+ continue
-+ res = res + " src/" + separate[1].strip()
-+ else:
-+ sys.stdout.write(res)
-+ sys.stdout.flush()
-+ break
-diff --git a/scripts/namelist.py b/scripts/namelist.py
-index cdac127..107ad00 100755
---- a/scripts/namelist.py
-+++ b/scripts/namelist.py
-@@ -14,23 +14,23 @@ import string
- import sys
-
- while 1:
-- data = sys.stdin.readline()
-- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- res = "%-32s = %s\n" % (separate[1], string.strip(separate[3]))
-- sys.stdout.write(res)
-- else:
-- sys.stdout.flush()
-- break
-+ data = sys.stdin.readline()
-+ if data != '':
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(';')
-+ if len(separate) != 4:
-+ continue
-+ res = "%-32s = %s\n" % (separate[1], separate[3].strip())
-+ sys.stdout.write(res)
-+ else:
-+ sys.stdout.flush()
-+ break
-
- def authorlist(mystr):
-- separate = string.split()
-+ separate = separate.split()
- for str in separate:
-- print string.strip(str)
-\ No newline at end of file
-+ print(str.strip())
-diff --git a/scripts/playlist.py b/scripts/playlist.py
-index 939d03d..e77b02a 100755
---- a/scripts/playlist.py
-+++ b/scripts/playlist.py
-@@ -14,27 +14,27 @@ import string
- import sys
-
- while 1:
-- data = sys.stdin.readline()
-- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- res = ""
-- # leave out all lines which don't have the proper number of elements
-- if len(separate) >= 1:
-- res = string.strip(separate[0]) + " = "
-- if len(separate) == 4:
-- res = res + separate[1]
-- res = res + "\n"
-- sys.stdout.write(res)
-- else:
-- sys.stdout.flush()
-- break
-+ data = sys.stdin.readline()
-+ if data != '':
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(';')
-+ res = ""
-+ # leave out all lines which don't have the proper number of elements
-+ if len(separate) >= 1:
-+ res = separate[0].strip() + " = "
-+ if len(separate) == 4:
-+ res = res + separate[1]
-+ res = res + "\n"
-+ sys.stdout.write(res)
-+ else:
-+ sys.stdout.flush()
-+ break
-
- def authorlist(mystr):
-- separate = string.split()
-+ separate = separate.split()
- for str in separate:
-- print string.strip(str)
-\ No newline at end of file
-+ print(str.strip())
-diff --git a/scripts/sanitize_list.py b/scripts/sanitize_list.py
-index f97709a..5368831 100755
---- a/scripts/sanitize_list.py
-+++ b/scripts/sanitize_list.py
-@@ -14,30 +14,30 @@ import string
- import sys
-
- while 1:
-- data = sys.stdin.readline()
-- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- res = ""
-- for str in separate:
-- if res != '':
-- res = res + ";" + string.strip(str)
-- else:
-- res = string.strip(str)
-- # end of data processing command group
-- res = res + "\n"
-- sys.stdout.write(res)
-- else:
-- sys.stdout.flush()
-- break
-+ data = sys.stdin.readline()
-+ if data != '':
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(';')
-+ if len(separate) != 4:
-+ continue
-+ res = ""
-+ for str in separate:
-+ if res != '':
-+ res = res + ";" + str.strip()
-+ else:
-+ res = str.strip()
-+ # end of data processing command group
-+ res = res + "\n"
-+ sys.stdout.write(res)
-+ else:
-+ sys.stdout.flush()
-+ break
-
- def authorlist(mystr):
-- separate = string.split()
-+ separate = separate.split()
- for str in separate:
-- print string.strip(str)
-\ No newline at end of file
-+ print(str.strip())
---
-2.27.0
-
diff --git a/games-misc/openmsx/openmsx-0.3.1-r5.ebuild b/games-misc/openmsx/openmsx-0.3.1-r5.ebuild
deleted file mode 100644
index f6dfaa4d3587..000000000000
--- a/games-misc/openmsx/openmsx-0.3.1-r5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit python-any-r1
-
-DESCRIPTION="Open source music base set for OpenTTD"
-HOMEPAGE="https://wiki.openttd.org/OpenMSX https://github.com/OpenTTD/OpenMSX"
-SRC_URI="https://cdn.openttd.org/openmsx-releases/${PV}/${P}-source.tar.gz"
-S="${WORKDIR}/${P}-source"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
-
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=( "${FILESDIR}"/${P}-python3.patch )
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_compile() {
- emake _V= bundle
-}
-
-src_install() {
- insinto "/usr/share/games/openttd/baseset/${P}"
- doins ${P}/{*.mid,openmsx.obm}
- dodoc ${P}/{changelog.txt,readme.txt}
-}