summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-08 07:41:40 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-08 07:42:34 +0200
commitfc43c93052184f27eee1e02c621b958086c3a653 (patch)
treeea1fdeedf80692a0ea0afe5c24d8f029c847da56 /games-misc
parentdev-ruby/trollop: add 2.9.10 (diff)
downloadgentoo-fc43c93052184f27eee1e02c621b958086c3a653.tar.gz
gentoo-fc43c93052184f27eee1e02c621b958086c3a653.tar.bz2
gentoo-fc43c93052184f27eee1e02c621b958086c3a653.zip
games-misc/lolcat: add 100.0.1
Closes: https://bugs.gentoo.org/634546 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/lolcat/Manifest1
-rw-r--r--games-misc/lolcat/lolcat-100.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/games-misc/lolcat/Manifest b/games-misc/lolcat/Manifest
index 3f3ede37f1f5..a08b66e3ee11 100644
--- a/games-misc/lolcat/Manifest
+++ b/games-misc/lolcat/Manifest
@@ -1 +1,2 @@
+DIST lolcat-100.0.1.gem 121344 BLAKE2B 0105987695990c93e2676babd238f10b586c8f742d40d35281cdf131b1db8ec019cd9c9c2cf1e6d8c248a9e9d2a7d5194aecc5b2fe09d04a11c7358b7d63bb61 SHA512 b257d264f8059e6722eaa66125b990414a77e8d67b47472a8e974418408bcf5fbc0a7c7f1e42517660280202ee2d669c3d3850d546356bd2f5e2e84e61af33ff
DIST lolcat-90.8.8.gem 56832 BLAKE2B 51bcd05f5bd277ae372b224d3ec8c0a041007ea70dc12261388655a6de8172017d88a1c58f58135181dfbfbc1ec63ab762a28db477618d1e80cf31d328885211 SHA512 2517a2e903c52d16c9773a32fae000917741a0b323abc19cdf4cad68f9ba873f059cda5790819e0d2cb057239dca9ac39a191f9e05417a91ef99f2232e8af3dd
diff --git a/games-misc/lolcat/lolcat-100.0.1.ebuild b/games-misc/lolcat/lolcat-100.0.1.ebuild
new file mode 100644
index 000000000000..43a1f78591e2
--- /dev/null
+++ b/games-misc/lolcat/lolcat-100.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="lolcat.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rainbows and unicorns!"
+HOMEPAGE="https://github.com/busyloop/lolcat"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "
+ dev-ruby/optimist:3
+ >=dev-ruby/paint-2.1:0"
+
+all_ruby_prepare() {
+ sed -e '/manpages/ s:^:#:' \
+ -e 's/git ls-files --/echo/' \
+ -e 's/git ls-files/find/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ doman man/lolcat.6
+}