summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-11-15 21:02:32 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-15 21:02:32 +0100
commit1416a450222921e213275d592b5c43e96f59e156 (patch)
treeee0d7943d2703b7385f3e276a952349da7d79599 /games-mud
parentmedia-libs/gst-plugins-base: fix src_configure with non-bash shells (diff)
downloadgentoo-1416a450222921e213275d592b5c43e96f59e156.tar.gz
gentoo-1416a450222921e213275d592b5c43e96f59e156.tar.bz2
gentoo-1416a450222921e213275d592b5c43e96f59e156.zip
games-mud/tf: fix build, fix version number
* Use debian patches * Fix usage of ncurses (thanks Petr Ĺ abata) * Remove debug USE flag which only was adding -g Closes: https://bugs.gentoo.org/710070 Closes: https://bugs.gentoo.org/706948 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/tf/Manifest1
-rw-r--r--games-mud/tf/tf-5.0_beta8_p8.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/games-mud/tf/Manifest b/games-mud/tf/Manifest
index 1e69e03b54d2..de8c02261010 100644
--- a/games-mud/tf/Manifest
+++ b/games-mud/tf/Manifest
@@ -2,3 +2,4 @@ DIST tf-50b8-help.tar.gz 175591 BLAKE2B b4b5d2be336206fa00db870367369454d33a7e32
DIST tf-50b8.tar.gz 719553 BLAKE2B 3218878cdc4a2049fd7f2a8e0426ec589bf304e0bb24ad557e5bea39cbaba76e6a1c52f064860e499623abb51bc9f14a0c8388b927fd15a66a7945fe5eaccf84 SHA512 3b99c039d7a9c6ab7ee7b1040ff7c99fe39cbe991f373333ea7c130d54383f102f14ae33303a415f5419cd43238caffc46114e842c6964329c0999e0f506e3d0
DIST tf-allrootpatch.txt 3349 BLAKE2B ca57b7ddfdbaa377c69ad07427185a3952368d35231f4bca77c78a5ed7b5c1c362f4ef1512e23c248b96810739056e8f53c4d41320a1c1dc320b1fd22d965199 SHA512 3fe44e7291d133abd04040f0f8258da6a2b7f67cab79cb1628897a4a483a0998495b6cf97eaf29ee447a650fdb16a48c846599807e570f687a256bb58179495e
DIST tf-allsrcpatch.txt 10392 BLAKE2B 9a24f99d6bdaa835b4cc2588d87824ea07a12fee38d576ec63f48493f5b92c7155ad959fa80599edf28a39f76d85ba8a2a19e1ff2b03c7893fe4d7b4b7d9af97 SHA512 3ac2447e05911d156509bb44e8809c06c4b1a92cbc8067d196c7e5f688fccd5186a9073001958ca0e757c9db20e9f96889fe7a5b6255495539f23208f72ec613
+DIST tf5_5.0beta8-8.debian.tar.xz 12732 BLAKE2B f663283d571c272e0c159c7175967a206ab30e95fb64b935c73fa1952a3e7ba559af104bf7d4640218bf5748968059f0f9e180cd1d1191beef4d8b0c472eefac SHA512 dcc220d7bec11dd3760104502c51aba320e7b6701b7b295ed188fa32edec7d23ac287995da6d08d34a55f937ccc53b6f02186afe4bbde02e934d90a57c7f52b1
diff --git a/games-mud/tf/tf-5.0_beta8_p8.ebuild b/games-mud/tf/tf-5.0_beta8_p8.ebuild
new file mode 100644
index 000000000000..a3910fb79ca7
--- /dev/null
+++ b/games-mud/tf/tf-5.0_beta8_p8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_p*/}"
+MY_PV="$(ver_rs 1 '' "${MY_PV}")"
+# 5.0_beta8_p8 -> 5.0beta8-8
+MY_DEB_PV="$(ver_cut 1-2)$(ver_cut 3-4)-$(ver_cut 6)"
+
+DESCRIPTION="A small, flexible, screen-oriented MUD client (aka TinyFugue)"
+HOMEPAGE="http://tinyfugue.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/tinyfugue/tf-${MY_PV}.tar.gz
+ mirror://debian/pool/main/t/tf5/tf5_${MY_DEB_PV}.debian.tar.xz
+ http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt -> tf-allrootpatch.txt
+ http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt -> tf-allsrcpatch.txt
+ doc? ( mirror://sourceforge/tinyfugue/tf-${MY_PV}-help.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+atcp doc +gmcp ipv6 +option102 ssl"
+
+RDEPEND="
+ dev-libs/libpcre
+ sys-libs/ncurses:=
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/tf-${MY_PV}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${DISTDIR}"/tf-allrootpatch.txt
+ "${DISTDIR}"/tf-allsrcpatch.txt
+ "${FILESDIR}"/tf-50_beta8-pcre.patch
+)
+
+src_configure() {
+ STRIP=: econf \
+ $(use_enable atcp) \
+ $(use_enable gmcp) \
+ $(use_enable option102) \
+ $(use_enable ssl) \
+ $(use_enable ipv6 inet6) \
+ --enable-manpage \
+ --enable-termcap=tinfo
+}
+
+src_install() {
+ dobin src/tf
+ newman src/tf.1.nroffman tf.1
+
+ use doc && HTML_DOCS=( ../${MY_P}-help/{*.html,commands,topics} )
+ einstalldocs
+
+ insinto /usr/share/${PN}-lib
+ # the application looks for this file here if /changes is called.
+ # see comments on bug #23274
+ doins CHANGES
+ insopts -m0755
+ doins -r tf-lib/.
+}
+
+pkg_postinst() {
+ if use ipv6; then
+ ewarn
+ ewarn "You have merged TinyFugue with IPv6-support."
+ ewarn "Support for IPv6 is still being experimental."
+ ewarn "If you experience problems with connecting to hosts,"
+ ewarn "try re-merging this package with USE="-ipv6""
+ ewarn
+ fi
+}