summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 12:08:57 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:50 +0200
commitefb2cb195e184870567c3a7170872c92c11642bc (patch)
tree7c830c056e303eedeca3e198cc31e296762dab67 /games-puzzle/4stattack
parentgames-misc/typespeed: Drop old (diff)
downloadgentoo-efb2cb195e184870567c3a7170872c92c11642bc.tar.gz
gentoo-efb2cb195e184870567c3a7170872c92c11642bc.tar.bz2
gentoo-efb2cb195e184870567c3a7170872c92c11642bc.zip
games-puzzle/4stattack: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/4stattack')
-rw-r--r--games-puzzle/4stattack/4stattack-2.1.4-r1.ebuild45
-rw-r--r--games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff4
2 files changed, 47 insertions, 2 deletions
diff --git a/games-puzzle/4stattack/4stattack-2.1.4-r1.ebuild b/games-puzzle/4stattack/4stattack-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..d04ec26a8f3f
--- /dev/null
+++ b/games-puzzle/4stattack/4stattack-2.1.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Connect-4 game, single or network multiplayer"
+HOMEPAGE="http://forcedattack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/forcedattack/4stAttack-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/4stAttack-${PV}"
+
+src_prepare() {
+ default
+
+ # move the doc files aside so it's easier to install the game files
+ mv README.txt credits.txt changelog.txt ..
+ rm -f GPL version~
+
+ # This patch makes the game save settings in $HOME
+ eapply "${FILESDIR}"/${P}-gentoo.diff
+}
+
+src_install() {
+ make_wrapper ${PN} "python2 ${PN}.py" /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r *
+ newicon kde/icons/64x64/forcedattack2.png ${PN}.png
+ make_desktop_entry ${PN} "4st Attack 2"
+ dodoc ../{README.txt,credits.txt,changelog.txt}
+}
diff --git a/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
index be7d32ed3ff2..9cb5be53b793 100644
--- a/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
+++ b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
@@ -1,5 +1,5 @@
---- 4stattack.py
-+++ 4stattack.py
+--- a/4stattack.py
++++ b/4stattack.py
@@ -28,6 +28,9 @@
images = None
screen = None