summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/braincurses
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/braincurses')
-rw-r--r--games-puzzle/braincurses/Manifest1
-rw-r--r--games-puzzle/braincurses/braincurses-0.5b.ebuild33
-rw-r--r--games-puzzle/braincurses/files/braincurses-0.5b-as-needed.patch27
-rw-r--r--games-puzzle/braincurses/files/braincurses-0.5b-gcc43.patch10
-rw-r--r--games-puzzle/braincurses/metadata.xml9
5 files changed, 80 insertions, 0 deletions
diff --git a/games-puzzle/braincurses/Manifest b/games-puzzle/braincurses/Manifest
new file mode 100644
index 000000000000..0d14ddd62c1b
--- /dev/null
+++ b/games-puzzle/braincurses/Manifest
@@ -0,0 +1 @@
+DIST braincurses-0.5b.tar.gz 18487 SHA256 c9adc662a30fdc51b36467e536ff5222b769ec73b35c7bddbd0ed4772c05f332 SHA512 7f90da3a5c480e0bf736dd4a53efc08abeb85969e727882e3d06f888b2a4b6002f9fd9bc1554ac2256c9821dea5fabf2638eba4a672046a09c1adb8690803a0e WHIRLPOOL 97829b1602e353714ec085a9ea635557c01911c935e0b6a13728d633026958ee9dd2e3903ca801cb2e24297c4702a325ace1d32908873cec985882a61edcb332
diff --git a/games-puzzle/braincurses/braincurses-0.5b.ebuild b/games-puzzle/braincurses/braincurses-0.5b.ebuild
new file mode 100644
index 000000000000..20227d193457
--- /dev/null
+++ b/games-puzzle/braincurses/braincurses-0.5b.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="An ncurses-based mastermind clone"
+HOMEPAGE="http://freshmeat.net/projects/braincurses/"
+SRC_URI="mirror://sourceforge/braincurses/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+ # fix buffer overflow (bug #301033)
+ sed -i \
+ -e 's/guessLabel\[2/guessLabel[3/' \
+ curses/windows.cpp \
+ || die 'sed failed'
+}
+
+src_install() {
+ dogamesbin braincurses
+ dodoc README THANKS Changelog
+ prepgamesdirs
+}
diff --git a/games-puzzle/braincurses/files/braincurses-0.5b-as-needed.patch b/games-puzzle/braincurses/files/braincurses-0.5b-as-needed.patch
new file mode 100644
index 000000000000..d1f36152403f
--- /dev/null
+++ b/games-puzzle/braincurses/files/braincurses-0.5b-as-needed.patch
@@ -0,0 +1,27 @@
+--- Makefile.old 2009-02-09 16:04:47.000000000 +0100
++++ Makefile 2009-02-09 16:14:41.000000000 +0100
+@@ -1,22 +1,9 @@
+ # Makefile for braincurses game
+ # written by Brian Derr
+
+-CC=g++
+-CFLAGS=-Wall
+-CURSES_LIBS=-lncurses
++LDLIBS=-lncurses
+
+-ncurses: curses/windows.o braincurses.o
+- ${CC} ${CURSES_LIBS} ${CFLAGS} -o braincurses curses/windows.o \
+- braincurses.o
+-
+-windows.o: windows.cpp
+- ${CC} ${CFLAGS} -c curses/windows.cpp
+-
+-braincurses.o: braincurses.cpp
+- ${CC} ${CFLAGS} -c braincurses.cpp
+-
+-#top_scores.o: top_scores.cpp
+-# ${CC} ${CFLAGS} -c top_scores.cpp
++braincurses: curses/windows.cpp braincurses.cpp
+
+ install:
+ install -o root -g root braincurses /usr/local/bin/
diff --git a/games-puzzle/braincurses/files/braincurses-0.5b-gcc43.patch b/games-puzzle/braincurses/files/braincurses-0.5b-gcc43.patch
new file mode 100644
index 000000000000..eafa39e4b9b8
--- /dev/null
+++ b/games-puzzle/braincurses/files/braincurses-0.5b-gcc43.patch
@@ -0,0 +1,10 @@
+--- braincurses.h
++++ braincurses.h
+@@ -12,6 +12,7 @@
+ #include <cstddef>
+ #include <cstdlib>
+ #include <ctime>
++#include <cstring>
+ #include <iostream>
+ #include <map>
+ #include <string>
diff --git a/games-puzzle/braincurses/metadata.xml b/games-puzzle/braincurses/metadata.xml
new file mode 100644
index 000000000000..f8159f79ec81
--- /dev/null
+++ b/games-puzzle/braincurses/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">braincurses</remote-id>
+ <remote-id type="freshmeat">braincurses</remote-id>
+ </upstream>
+</pkgmetadata>