summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter-Levine <plevine457@gmail.com>2017-03-24 12:58:20 -0400
committerDavid Seifert <soap@gentoo.org>2017-03-25 13:47:35 +0100
commita3f18aaa61a2e2b0ce2e97bb4082d66fb794197c (patch)
tree7162a6ee469566fabef1f4335331a36b2ce23477 /games-puzzle/brainparty/brainparty-0.61-r1.ebuild
parentgames-puzzle/brainparty: Fix GCC-6 build (diff)
downloadgentoo-a3f18aaa61a2e2b0ce2e97bb4082d66fb794197c.tar.gz
gentoo-a3f18aaa61a2e2b0ce2e97bb4082d66fb794197c.tar.bz2
gentoo-a3f18aaa61a2e2b0ce2e97bb4082d66fb794197c.zip
games-puzzle/brainparty: Revbump for EAPI 6 support
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4220
Diffstat (limited to 'games-puzzle/brainparty/brainparty-0.61-r1.ebuild')
-rw-r--r--games-puzzle/brainparty/brainparty-0.61-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-puzzle/brainparty/brainparty-0.61-r1.ebuild b/games-puzzle/brainparty/brainparty-0.61-r1.ebuild
new file mode 100644
index 000000000000..97d4b35c28aa
--- /dev/null
+++ b/games-puzzle/brainparty/brainparty-0.61-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A puzzle-solving, brain-stretching game for all ages"
+HOMEPAGE="http://www.tuxradar.com/brainparty"
+SRC_URI="https://launchpad.net/brainparty/trunk/${PV}/+download/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-savegame.patch
+ "${FILESDIR}"/${P}-gcc49.patch
+ "${FILESDIR}"/${P}-gnu_cxx-hash.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/$(LIBS) $(OSXCOMPAT) $(OBJFILES)/$(OSXCOMPAT) $(OBJFILES) $(LIBS)/' \
+ -e 's/CXXFLAGS = .*/CXXFLAGS+=-c/' \
+ -e '/^CXX =/d' \
+ -e '/-o brainparty/s/INCLUDES) /&$(LDFLAGS) /' \
+ Makefile || die
+ sed -i \
+ "/^int main(/ a\\\\tchdir(\"/usr/share/${PN}\");\n" \
+ main.cpp || die
+}
+
+src_install() {
+ dobin brainparty
+
+ insinto /usr/share/${PN}/Content
+ doins -r Content/.
+
+ newicon Content/icon.bmp ${PN}.bmp
+ make_desktop_entry brainparty "Brain Party" /usr/share/pixmaps/${PN}.bmp
+}