summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 05:39:52 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:50 +0000
commit2f130cbc436802aec76e378e1b63488004fb2966 (patch)
tree3fef30e48cf4daaae9a19e78bd0e3b889cb9a849 /games-puzzle/brainparty/brainparty-0.61-r2.ebuild
parentgames-puzzle/brainworkshop: eutils->edos2unix (diff)
downloadgentoo-2f130cbc436802aec76e378e1b63488004fb2966.tar.gz
gentoo-2f130cbc436802aec76e378e1b63488004fb2966.tar.bz2
gentoo-2f130cbc436802aec76e378e1b63488004fb2966.zip
games-puzzle/brainparty: eutils->desktop, missing glu+gl deps
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle/brainparty/brainparty-0.61-r2.ebuild')
-rw-r--r--games-puzzle/brainparty/brainparty-0.61-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-puzzle/brainparty/brainparty-0.61-r2.ebuild b/games-puzzle/brainparty/brainparty-0.61-r2.ebuild
new file mode 100644
index 000000000000..ea625a5d9849
--- /dev/null
+++ b/games-puzzle/brainparty/brainparty-0.61-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="A puzzle-solving, brain-stretching game for all ages"
+HOMEPAGE="http://www.tuxradar.com/brainparty"
+SRC_URI="https://launchpad.net/brainparty/trunk/${PV}/+download/${PN}${PV}.tar.gz"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ virtual/opengl
+ virtual/glu
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-savegame.patch
+ "${FILESDIR}"/${P}-gcc49.patch
+ "${FILESDIR}"/${P}-gnu_cxx-hash.patch
+ "${FILESDIR}"/${P}-gcc-11.patch
+ "${FILESDIR}"/${P}-clang-11.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/$(LIBS) $(OSXCOMPAT) $(OBJFILES)/$(OSXCOMPAT) $(OBJFILES) $(LIBS)/' \
+ -e 's/CXXFLAGS = .*/CXXFLAGS+=-c/' \
+ -e '/^CXX =/d' \
+ -e '/-o brainparty/s/INCLUDES) /&$(LDFLAGS) /' \
+ Makefile || die
+ sed -i \
+ "/^int main(/ a\\\\tchdir(\"/usr/share/${PN}\");\n" \
+ main.cpp || die
+
+ tc-export CXX
+}
+
+src_install() {
+ dobin brainparty
+
+ insinto /usr/share/${PN}/Content
+ doins -r Content/.
+
+ newicon Content/icon.bmp ${PN}.bmp
+ make_desktop_entry brainparty "Brain Party" /usr/share/pixmaps/${PN}.bmp
+}