summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/construo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/construo')
-rw-r--r--games-puzzle/construo/Manifest1
-rw-r--r--games-puzzle/construo/construo-0.2.2.ebuild40
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-gcc43.patch82
-rw-r--r--games-puzzle/construo/files/construo-0.2.2-lGLU.patch18
-rw-r--r--games-puzzle/construo/metadata.xml5
5 files changed, 146 insertions, 0 deletions
diff --git a/games-puzzle/construo/Manifest b/games-puzzle/construo/Manifest
new file mode 100644
index 000000000000..899aae692714
--- /dev/null
+++ b/games-puzzle/construo/Manifest
@@ -0,0 +1 @@
+DIST construo-0.2.2.tar.gz 442626 SHA256 93b1dc5c26aab42d886f102e501189982c28d390f8b573f8f4a42bad640ec630
diff --git a/games-puzzle/construo/construo-0.2.2.ebuild b/games-puzzle/construo/construo-0.2.2.ebuild
new file mode 100644
index 000000000000..07653eb74bbf
--- /dev/null
+++ b/games-puzzle/construo/construo-0.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="2d construction toy with objects that react on physical forces"
+HOMEPAGE="http://www.nongnu.org/construo/"
+SRC_URI="http://freesoftware.fsf.org/download/construo/construo.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-lGLU.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --datadir="${GAMES_DATADIR_BASE}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ bindir="${GAMES_BINDIR}" install
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}
diff --git a/games-puzzle/construo/files/construo-0.2.2-gcc43.patch b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
new file mode 100644
index 000000000000..cc946b043bae
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-gcc43.patch
@@ -0,0 +1,82 @@
+--- command_line.cxx
++++ command_line.cxx
+@@ -19,7 +19,9 @@
+
+ #include <config.h>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+ #include "settings.hxx"
+ #include "command_line.hxx"
+
+--- config.hxx
++++ config.hxx
+@@ -21,6 +21,7 @@
+ #define CONFIG_HH
+
+ #include <string>
++#include <cstdlib>
+
+ class Config
+ {
+--- lisp_reader.cxx
++++ lisp_reader.cxx
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstring>
+ #include "construo_error.hxx"
+ #include "lisp_reader.hxx"
+
+--- unix_system.cxx
++++ unix_system.cxx
+@@ -17,8 +17,9 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <stdio.h>
+-#include <assert.h>
++#include <cstdio>
++#include <cassert>
++#include <cstring>
+ #include <unistd.h>
+ #include <sys/time.h>
+ #include <time.h>
+--- vector.cxx
++++ vector.cxx
+@@ -16,8 +16,8 @@
+ totally replaced old CL_Vector with this code
+ */
+
+-#include <assert.h>
+-#include <math.h>
++#include <cassert>
++#include <cmath>
+ #include "vector.hxx"
+
+ CL_Vector::CL_Vector(float x, float y, float z, float w)
+--- world.cxx
++++ world.cxx
+@@ -17,7 +17,8 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-#include <assert.h>
++#include <cassert>
++#include <cstring>
+ #include <algorithm>
+ #include "config.h"
+
+--- x11_display.cxx
++++ x11_display.cxx
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <iostream>
++#include <cstring>
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <X11/keysym.h>
diff --git a/games-puzzle/construo/files/construo-0.2.2-lGLU.patch b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
new file mode 100644
index 000000000000..4c0b018cfdc1
--- /dev/null
+++ b/games-puzzle/construo/files/construo-0.2.2-lGLU.patch
@@ -0,0 +1,18 @@
+--- configure.ac.old 2009-11-24 18:27:48.000000000 +0100
++++ configure.ac 2009-11-24 18:28:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ AC_CHECK_LIB(glut, glutMainLoop,
+ [
+ ConstruoTargets="$ConstruoTargets construo.glut"
+- AC_SUBST(glut_LIBS,"-lglut")
++ AC_SUBST(glut_LIBS,"-lglut -lGLU -lGL -lm")
+ ],
+ [])
+
+@@ -158,4 +158,4 @@
+ echo " Ingo Ruhnke <grumbel@gmx.de>"
+ echo ""
+
+-# EOF #
+\ No newline at end of file
++# EOF #
diff --git a/games-puzzle/construo/metadata.xml b/games-puzzle/construo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/construo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>