summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-29 12:27:27 +0300
committerMart Raudsepp <leio@gentoo.org>2020-03-29 12:55:37 +0300
commit9c104e3ada49bda8eb1cd69a516d9505695496bf (patch)
treeb7e80162e14c5d3f828ca051432c6114fbaae35e /games-puzzle/five-or-more/five-or-more-3.32.2.ebuild
parentdev-python/stripe: Remove redundant longdesc (diff)
downloadgentoo-9c104e3ada49bda8eb1cd69a516d9505695496bf.tar.gz
gentoo-9c104e3ada49bda8eb1cd69a516d9505695496bf.tar.bz2
gentoo-9c104e3ada49bda8eb1cd69a516d9505695496bf.zip
games-puzzle/five-or-more: bump to 3.32.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-puzzle/five-or-more/five-or-more-3.32.2.ebuild')
-rw-r--r--games-puzzle/five-or-more/five-or-more-3.32.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-puzzle/five-or-more/five-or-more-3.32.2.ebuild b/games-puzzle/five-or-more/five-or-more-3.32.2.ebuild
new file mode 100644
index 000000000000..349ab537831b
--- /dev/null
+++ b/games-puzzle/five-or-more/five-or-more-3.32.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Remove colored balls from the board by forming lines"
+HOMEPAGE="https://wiki.gnome.org/Apps/Five%20or%20more"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libgee:0.8=
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.20:3
+ dev-libs/libgnome-games-support:=
+ >=gnome-base/librsvg-2.32:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}